The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Error 509 when connecting to Jira

Toomas Adson
Contributor
May 22, 2025

When connectiong via api to Jira Cloud, I get following error:

https://projektid.atlassian.net/rest/api/2/instance/licence: tls: failed to verify certificate: 509: certificate signed by unknown authority.

 

Where to start with solving? Could the API key I created have issues?

2 answers

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

1 vote
Tuncay Senturk _Snapbytes_
Community Champion
May 22, 2025

Hi @Toomas Adson 

509 error indicates that there is a certificate/trust issue, not a problem with the API key itself. Possibly your TLS is failing to verify Atlassian's SSL certificate. It may be because that you are behind a corporate proxy or firewall which may be blocking the certificate or replacing with the self-signed ones.

So, I'd suggest (as @marc -Collabello--Phase Locked- mentioned) to visit that URL in your browser, if you get a cert warning, it means that the issue is with your local store.

0 votes
marc -Collabello--Phase Locked-
Community Champion
May 22, 2025

Try to reach the URL from a browser and have a look at the response.

This will often help.

DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Product Admin
TAGS
AUG Leaders

Atlassian Community Events