I keep seeing this configuration error which is blocking me from using other channel-features like the 'widget' not until this gets resolved.
However, based on the problem shown in the screenshot; email request type requires a summary and description and they should not be restricted BUT the currently created email-request-type by JIRA won't allow me to turn off 'required' option on the 'Summary' field and there is no option to add a 'Description' field.