Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trello board Invites not being sent

I can't seem to invite anyone to any new Trello boards that I create.

I hit the Invite button, add a person's email address, click "Send Invitation" and then nothing happens ... there's no confirmation that the person was invited, no indication that the invite was sent and is waiting to be accepted, and I have confirmed with the people that I've invited that they do not receive an invitation email. There is also no error message telling me that something went wrong or that I'm doing something wrong. 

I've also tried inviting people that I already collaborate with on other Trello boards, or new people that have never used Trello before.

I'm flummoxed! And completely stuck. 

2 answers

Hi @Andrew Aitken ,

Welcome to the community!

Please go through this guide https://help.trello.com/article/717-adding-people-to-a-board

sometimes it takes a few hours to send by email but you can use the username to invite!

https://help.trello.com/article/1024-invite-people-by-using-a-shareable-link

When I send the link to someone, and they click on the link, they get the following error message:

trelloerror.png

Like Soumyadeep Mandal likes this

Hi @Andrew Aitken ,

That means you have clicked the disable button just beside the share link option!

Follow the steps again carefully or add members by Username!

OK. So the screengrab below shows how I copied the link. You can see that the Disable Link is visible, but I have not clicked on it. 

I copy the link, and email it to a user. 

The user clicks on the link within minutes of receiving the email. And gets the same error message I showed above. So the problem is not as you've described. 

I'm still flummoxed! 

 

trelloerror2.png

I also tried inviting the user by username. I type the person's username into the "email address or username" field, find the correct user and select them, then hit the green "Send invitation" button. The icon for the user that I've invited appears next to my user icon (to the left of the "invite" button) for a fraction of a second, and then vanishes, leaving just me as a member of the board. The user never receives the invitation. 

I really am still flummoxed! 

This problem seems to have started to manifest around the time that Trello combined with Atlassian, i.e. after my Trello login process had to get combined with some sort of Atlassian authentication process.

Is there a way for me to get direct support on resolving this issue? 

It still remains a big problem for me. 

Like Soumyadeep Mandal likes this

You can ask Trello support HERE

YOU STILL DIDN'T FIX THIS?!?!?!?!?!?!?!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

📹 What is Trello?

Hello Community!  My name is Brittany Joiner and I am a Trello enthusiast and Atlassian Community Leader. I'll be sharing with you a series of videos with my top tips on how to best use Trello...

817 views 13 30
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you