Hi, just upgraded to the premium free trial, now can't login to Trello

David Haberfield
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 21, 2024

Ive been using Trello Free for a while. Yesterday I agreed to 14 day free trial of trello Premium. Today, I cannot login to any Trello site, get the following message


This site can’t be reached

trello.com took too long to respond.



1 answer

1 vote
Pramodh M
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 21, 2024

Hi @David Haberfield 

There must have been some misconfiguration in the local system.

Check whether other Atlassian links are accessible (id.atlassian.com, start.atlassian.com, team.atlassian.com)

Have you tried accessing Trello through mobile or other devices? Has it worked?

If you login to trello.com, you should be able to see the workspaces as well.

Let me know how it goes

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events