Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Direct URLs to Individual Cards are Just Auto-Redirecting to the Board URL Instead, How to Fix?

Riley _Mythimorph_ February 7, 2024

I use Trello to help clients keep track of their order status. I provide them a URL directly to the card itself via the card's "share" button. I have verified the board & cards are all public.

Instead of the link taking the client to their card, it automatically re-directs them to the board that the card lives in & the "About this Board" popup appears instead of their card.

I have tried this myself & confirm that in incognito mode it will redirect to the board, but if I am logged in or using the mobile app, these links function correctly & will display the card without issue.

I really, really don't want to force all my clients to get Trello accounts just to be linked to their card & it did not use to function this way. Is this a bug, a new feature, or is there a setting somewhere to adjust this behavior? Because Trello is pointless if I can't easily share the info my clients need access to.

For now I have given them instructions on how to use filters to locate it manually, but I have hundreds of cards so this is really inconvenient.

2 answers

1 accepted

1 vote
Answer accepted
Riley _Mythimorph_ March 6, 2024

The mystery has been solved! Or at least partly—support will be looking into the reported bug—but for now they have given me a workable solution:

Deleting the board description entirely makes the pop-up go away.
This solves the issue of the redirect & card URLs now function properly.


I already had an “info card” on the board I share with clients mirroring the pop-up's text, so this is a perfectly acceptable solution for me to just forgo using the designated board description field. If I do want to continue displaying a "pop-up description" when someone visits the board, I'd simply need to provide the URL to the info card instead. Simple!


Thank you to @Tymek for assistance in troubleshooting with me :)

Tymek March 7, 2024

@Riley _Mythimorph_ nice to hear that, happy to help!

0 votes
Tymek February 8, 2024

@Riley _Mythimorph_ 

As far as I know, the links to the cards should work correctly both when you're logged in and in incognito mode. I tested it for my boards and it worked. 

It's possible that some installed power-ups changed this behavior. What power-ups do you have enabled in this board? Also, what browser do you use?

Riley _Mythimorph_ February 15, 2024

Appreciate the reply! That was my first thought as well, so I went through every single power-up setting, completely wiped data on unused ones, & I'm still without any luck.

(My power ups: Amazing Fields, Tiny Power-Ups Club [Archive Manager, Durations, Gallery View, Saved Filters], & I'm in the middle of migrating data from Notes & Docs to Private Notes)

But I tried making a brand new board from scratch with no power-ups at all & I'm still getting the same behavior.

Browser is Chrome, up-to-date as of the time of this writing

Riley _Mythimorph_ February 15, 2024

Hmmm, got a behavior I didn't see before: Wiping cookies & using incognito, looks like upon first load it only shows the "About this board" info as a pop-up...

BUT if that board has been cached & then the card link is used, it does in fact bring up the card but also the "About this board" pop-up over it.


Trying to figure out what may be causing the pop-up in the first place & if that's overriding something but I cannot find a setting to adjust this behavior. I had also previously experimented with a power-up called "Read Me" on this board which is created by Trello, but never got it to work so the data on that power-up was wiped.

Tymek February 16, 2024

Would you be able to create a public board with this problem and send it's URL here? We may be able to troubleshoot it on our end.

Riley _Mythimorph_ February 16, 2024

Made a new board from scratch & here's a link to the card: https://trello.com/c/O6PL11iH

I confirmed it's giving me the same behavior. No power-ups are active on this board, but my account has certainly granted permission to a handful of power-ups that have access to all my boards. One of them could be the culprit, but I have a lot of important personal data & I don't want to lose that by systematically testing them all, if I can help it.

Tymek February 19, 2024

It works for me. The board is loaded with the Test Card opened. 

I would try to use another browser and clear the Trello website cache. It is weird though that all yours clients experience this behavior. Is it possible that they all use the same browser? 

Riley _Mythimorph_ February 19, 2024

Well that's just really bizarre! Though I'm quite glad that you're not experiencing my issue. I still feel like it has to be on Trello's end the more I try to troubleshoot this & you just caught it on a good day ;)


I verified it also is not working when using the Edge browser on my machine (which I know is also based on Chromium). So I installed Firefox too, no change.

Just now went to go try on my laptop as well... new issue I haven't been able to replicate again, but going to the card link first showed me a board that was locked instead of public, saying something to the effect like "you need to sign up to see this board"... but then after a few seconds it went away & auto-refreshed the page, going back to the behavior this thread is about. (!?)

I definitely have tried wiped my cache in all these tests too with no further luck. I'm not even getting that behavior I saw on Feb 15 anymore, which I thought was cache-related.

I do super appreciate your continued assistance with this though, so thank you!

The mystery continues...

Riley _Mythimorph_ March 5, 2024

@Tymek When you tested my direct card link earlier (https://trello.com/c/O6PL11iH) were you logged in to Trello by chance? Could you try logging out (or using incognito) & test it again?

Everyone else I've tried sending this link to doesn't have a Trello account (including most of my clients) & you're the only one who has reported the link working correctly, so I suspect that is why.

I have also opened a support ticket to investigate this bug further.

Tymek March 6, 2024

@Riley _Mythimorph_ 

Apologize for this, now I tested it on an incognito mode and you're right - the "About the board" popup appears every time after page loads.

Like Riley _Mythimorph_ likes this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events