Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

why is Commit not working on SourceTree?

I am testing SourceTree,  but when I click on Commit to commit a text file, nothing happens. Can you explain what is the cause of this issue please?


2 answers

Also I had this problem, and we were not the only one, several communities discussed this behavior.

My colleague found a funny work around. It works on  Windows 7 using two screens:

Drag your SourceTree window upwards or away from the 1st screen towards the 2nd screen. This way, the commit button is out of the right-bottom area of your screen.

In my opinion a Windows related issue. For example, at this moment, also my scrollbars in IntelliJ aren't accessible in this area of the screen.

Superb, worked for me. By decreasing the screen size, Commit button is actually enabled and worked as usual

Great. Decreasing the screen size works for me also. I can commit now.

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 16, 2019

Hi @pierreborg,

I'm not quite clear on what you mean by "click on Commit".

- Are you clicking the Commit toolbar item, or the Commit button in the File Status view?

- Is the file marked as changed?

- Does committing the text file via CLI work and this is specific to ST?

Hopefully we can get to the bottom of this ASAP.

Brian Ganninger
Principal Developer, Sourcetree

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events