Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,389
Community Members
 
Community Events
165
Community Groups

"Too many invalid password attempts. "

Edited

OK this is not fun at all. I've got two PCs, both running SourceTree. I'm moving my development environment across from my old PC to my new one. SourceTree was functioning perfectly fine on both, until today on my new PC when I started getting the infamously dreaded "Too many invalid password attempts. Log in at https://id.atlassian.com/ to restore access." error when trying to push changes or clone a repository. Bizarrely, the this does not happen with the SourceTree on my old PC, which seems to be working fine. I've tried the following;

  • logged in at https://id.atlassian.com/ as the error message says to do
  • refreshed OAuth tokens
  • changed my BitBucket password
  • removed and added my user in SourceTree
  • reinstalled SourceTree

I'm essentially stuck, I can't push up my changes which means the rest of my team can't progress work on this project any further. Does anyone have any ideas? 

2 answers

2 accepted

2 votes
Answer accepted

Luckily I have managed to resolve this. My solution, in case this helps somebody, was to go to the main menu, Tools > Options > Git tab then update my Git version using the "Update Embedded" button. Hell of a thing.

This saved me... thank you sir

1 vote
Answer accepted

Was able to pull using the command line (git pull origin), but unable to with SourceTree.

 

After trying many different suggestions, I installed git from git-scm.com.

Then in SourceTree went to Tools > Options > Git > Git Version

Selected "System" button.

Restarted SourceTree.

Now able to pull without "too many invalid password attempts".

Hi @DCourage good one. This sounds like what I did, in a round-about way, which is to update the installed Git version, or switch to using an updated version.

This worked for me. Thank you! 

Sidenote: I also closed my coding environment with pycharm which is linked to sourcetree, before doing any of these steps. 

Finally, I reverted back to version 3.4.5, just fyi

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

60,269 views 127 26
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you