Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"Older Version Of Sourcetree Cannot Be Removed" - Can't Uninstall or Reinstall Sourctree

I'm having a similar problem as the person in this question, but the answer that has been marked as "correct" is a solution that no longer works.

answers.atlassian.com/questions/300711/the-older-version-of-sourcetree-cannot-be-removed

I've been trying to upgrade Sourcetree to the latest. I kept getting "The older version of SourceTree cannot be removed". I've deleted the Sourcetree files and the SourceTree local data. 

The Microsoft Installer Fixit tool the was recommended in the answer above is no longer available at the provided url. When I search for it, I get a message that says it is not supported on my version of Windows (I'm running Windows 10).

I need help here. I can't reinstall Sourcetree and I can't uninstall SourceTree.

6 answers

1 accepted

9 votes
Answer accepted

I seemed to have an old one stuck in the registtry which can be found at or near: HKEY_CLASSES_ROOT\Installer\Products\{GUID} - do a search for "sourcetree".

I uninstalled all version in the normal way from add/remove programs then I exported the key first just in case and then deleted it and the installer ran fine.

That did it! You are a giant among men.

Finally this solved my problem. Thanks

Thanks, that helped.

Thank you! I want to add that I was unable to "uninstall" using Windows Feature and Programs. So what I did was I deleted the entry, tried to uninstall one more time (it didnt work), then I deleted the sourcetree folder below Atlassian!

Hey, I do have same problem - cannot neither install new version (1.8.3) nor uninstall any previous - no previous versions visible in any uninstall tools.

I already delete every f**ing regystry entry point with "sourcetree" word

Do same with HDD.

No progress :sad:

And this is 3rd or 4th time happening for last year.

FIXED!!!

In many cases, the problem is with MSI registry - corrupted reg.

Here is the only tool can fix corrupted MSI registry: https://support.microsoft.com/en-gb/mats/program_install_and_uninstall/en

It worked for me too,

upgrading 1.8.3 to 1.9.5

 

After receiving Atlassian's email about security vulnerability in versions prior to 2.0.20 I was trying to uninstall 1.9.10.

It did not work. I ended up finding the installer for this version (mental note: keep the installers!), installing it and then uninstallng. That worked.

Hi,

I have the exact same issue. 

Maybe the solution is to try and remove sourcetree manually? (and not through Microsoft installer)

Atlassian support: Could you share instructions on how to remove sourcetree completely from windows?

In many cases, the problem is with MSI registry - corrupted reg.

Here is the only tool can fix corrupted MSI registry: https://support.microsoft.com/en-gb/mats/program_install_and_uninstall/en

I had the same issue when updating to version 2.0. I could see there were a lot of installed SourceTrees <v2.0, but the registry entry seemed to be corrupt. When I deleted them from HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432\Microsoft\Windows\CurrentVersion\Uninstall (not that WOW6432 might be left out in some cases) it worked. There was one key ("folder") per installation

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

5,268 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you