missing logo icon in SourceTree window

missing logo icon in SourceTree window: white circle instead of custom logo image.

 

SourceTree version: 2.0.5.2 (2.0.5.2)

OS: OS X 10.10.3

 

here is a screenshot:

SourceTree:

スクリーンショット 2015-06-17 21.14.09.png

bitbucket page on Chrome

 

スクリーンショット 2015-06-17 21.13.50.png

 

regards.

23 answers

This widget could not be displayed.

Doing this fix the problem for me:

First, quit SourceTree completely.

Then remove ALL the files under: 

~/Library/Application\ Support/SourceTree/ImageCache/


Which can be achieved by running following command in terminal

rm -v ~/Library/Application\ Support/SourceTree/ImageCache/*

 

Start SourceTree, you will see all your repositories will have the default icons now and just wait the customized icon to be downloaded.

 

FYI, I am using OSX 10.9.5 and SourceTree 2.0.5.2

Tried that. I actually tried trashing ALL preferences, cache etc... Restarted everything and re-input all repositories. Not only did it not fix the the problems with the other random missing logos, but all logos are gone. I've tried using variations of SSH / HTTPS etc... Any other suggestions... ? I'm using OS X 10.11 and SourceTree 2.0.5.3

I also tried it, just defaulted all logos to default. Used to work fine so I don't know why they can't fix it. I'm using OSX 10.10.5 and SourceTree 2.0.5.5

Sorry for the late reply, as I can only post one comment per day due to new account restriction :( Anyway, I actually did the all same as @Drew did, however removing the image cache is the only successful attempt. Also, there is an file named *RepoAvatarURLCache* in the ImageCache folder, make sure you delete it too. I get a lot of blank icons if I leave it there, and it seems prevent SourceTree from generating new icon caches, deleting it brings everything back on the track. Since we are using different versions of OSX, maybe do some search with the filename? I can confirm it is working on my machine at least. @George, Yes, this is a newly introduced bug, I cannot remember since when, but I have seen it for couple of months. If it really bothers you that much, maybe roll back to SourceTree 1, which is available from App Store, I have used it for a while and I didn't see much differences except the "old-fashion" UI (pre-Yosemite).

This widget could not be displayed.

+1

This widget could not be displayed.

To show icons at sourcetree window, add your icon file to project root folder as 'icon.png' named.

 

This widget could not be displayed.

SourceTree.png

This widget could not be displayed.

I'm having the same issue.

Version 2.0.5.2 (2.0.5.2) on iMac 5k 10.10.4 (14E46)

Screen Shot 2015-08-04 at 10.52.32 PM.png

This widget could not be displayed.

Please comment here:  https://jira.atlassian.com/browse/SRCTREE-3082

It does appear they are working on the problem though.

This widget could not be displayed.

+1. Experiencing the same issue. Using the same OS and SourceTree version.

This widget could not be displayed.

Same problem here on 2.0.5.2

This widget could not be displayed.

I'm having the same issue on OS X 10.10.4 and SourceTree 2.0.5.2.

This widget could not be displayed.

Same here sourcetree 2.0.5.2 (2.0.5.2) and OSX 10.10.3

This widget could not be displayed.

Same here on all our Macs 10.8 through 10.10. Been like this for a few weeks now

This widget could not be displayed.

Same issue for me as well... when can this get fixed?

This widget could not be displayed.

Same issue for me, but only on one machine. On my Mac Pro and SourceTree logos all appear fine. On my MacBook Pro all logos are missing as above. Both machines running the current stable OS and SourceTree version. Mac OS v10.10.4, SourceTree v2.0.5.2.

This widget could not be displayed.

+1 Same SourceTree version (2.0.5.2) but I'm running OS 10.10.4 All BitBucket repo logos are missing. GitHub logos are all the plain bucket on blue background.

This widget could not be displayed.

Same issue on MacOSX for quite a while now, across updates of both MacOSX and SourceTree. Even the default image would be better than the annoying empty circle :-(

This widget could not be displayed.

Same problem... Version 2.0.5.2 (2.0.5.2). BitBucket logos are blank. GitHub logos are the standard bucket on a blue background. Fix please? Very annoying!

This widget could not be displayed.

Same problem as of July 31...the "refresh logo" command does not work.

This widget could not be displayed.

+1 on latest SourceTree and OS X

This widget could not be displayed.

+1 Here. Refresh logos also does not work.

This widget could not be displayed.

+1 Same thing here. Been like this for ever.

This widget could not be displayed.

+1 Same problem too - has anyone managed to get a definitive answer to this question?

This widget could not be displayed.

Same problem. Any updates on this?

This widget could not be displayed.

Aaaaaaannd..... that's more than two years have passed and still no icons!
And I distinctly remember this thing used to work.

Sourcetree 2.6.3 (134) / macOS Sierra 10.12.6 (16G29)

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

724 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you