Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

git-svn with error

Armin Inauen February 4, 2019

If I try to commit or update a subversion repository with Sourcetree I get the following error:

git --no-optional-locks -c color.branch=false -c color.diff=false -c color.status=false -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree svn rebase 

String found where operator expected at /Applications/ line 885, near "fatal "trees ($treeish) $y != $x\n""

(Do you need to predeclare fatal?)

syntax error at /Applications/ line 885, near "fatal "trees ($treeish) $y != $x\n""

BEGIN not safe after errors--compilation aborted at /Applications/ line 1670.

Compilation failed in require at /Applications/ line 42.

BEGIN failed--compilation aborted at /Applications/ line 42.

Completed with errors, see above

searched the web, but couldn't find a clue.

SourceTree: Version 3.0.1

Mac OS: Mojave Version 10.14.3

2 answers

0 votes
Alexander Thalhammer
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 6, 2019

Same problem when I try "git svn", can't find any solution nowhere.

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 4, 2019

Hi @Armin Inauen,

It looks like you might be using "System Git" in Sourcetree, which is pointing to Xcode's current implementation. Do you encounter the same error if you use "Embedded Git" instead?


Brian Ganninger
Principal Developer, Sourcetree

Armin Inauen February 4, 2019

Hi Brian,

if I use "Embedded Git 2.18.0" I got the same error message.

Armin Inauen February 12, 2020

Hi Brain,

any news about that "fatal" Error?

Best regards


Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events