git push fails and throws three errors

We are using Team Foundation Server 2013 Update 3 as our Git Server and SourceTree to manage our Repositories with Git Flow.

Two of our (14) developers cannot push changes from their local /develop-branch to origin. Both get this error log:

sourcetree.PNG

Now I've done some research and testing and this is what I've found out:

  • Yesterday only one of the two devs could not push. Today the second dev could not push anymore (He did push yesterday though.)
  • Both can still push to other remote branches, like shared-feature-branches. So far it is only happing when they try to push to origin/develop.
  • They can still push to origin/develop using Git via Visual Studio 2013.
  • I could not find any reference to the error message: 'fatal: protocol error: bad line length character: ent-'. There were different parameters, not 'ent-'.
  • I have tried to extend the [http] postBuffer

 

Do you have any idea how to solve this problem? 

3 answers

I think your problem is with TFS doing something in a non-standard way, try asking on a MS forum.

Another thing that might be worth looking at is the core.autocrlf setting in the people's .gitconfig files. If the one/two people have a different setting than the rest, this might be connected. (As far as I know, this is the only client-side setting that could be relevant.)

I had this exact problem and never did find a solution. Except, until I ran across your question and saw that while you couldn't push from SourceTree (I couldn't push from console either), you *could* push from Visual Studio - which I hadn't thought to try. I tried, and it worked! Thank you.

I am glad this post did help you. Neither did I find a better solution yet. But today I have learned that after pushing (/resolving the problem) from Visual Studio, you are able to push from SourceTree again. Strangely, it seems to be a temporary issue.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

841 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you