Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

'git log' failed with code -1:'launch path not accessible----- how can I solve this problem?

my sourcetree  got some error when I try to open my repo:'git log' failed with code -1:'launch path not accessible

I am not sure whether  I made a mistake in deleting some file to cause this thing,  anyway ,now how can I do to solve this error?

4 answers

I didn't have to reinstall git I just had to tell SourceTree what git executable to use. I'm on OSX Yosemite (10.10.3) with a Homebrewed git install so I opened SourceTree and navigated to SourceTree...Preferences and selected the Git Tab. I then clicked "Use System Git" and navigated to /usr/local/Cellar/git/2.3.5/bin/git.

Worked for me! Thank you!

Worked for me, too. Hooray!

Fantastic explanation of the fix. 

pix I'm New Here Apr 18, 2020

went to preferences, git, clicked the system git button, it automatically opened the right path, clicked on git, thats it, fixed.. osx catalina

If you reinstall Git (no need to uninstall it first, just start the installer again), any accidentally removed files will be put back. (In SourceTree, make sure you are using the system Git, not the embedded one. The option is in Tools\Options\Git.)

reinstall Git?which didn't cause my current repos disappear? I already built many repo in sourcetree and used them for a long time, until recently I just clear some trash for my hd , after that, when I open any repo, then show the error I posted in the title

Reinstalling Git will not change your clones in any way.

When you say you cleared trash, did that trash include ".git" folders? If so, you've deleted your repositories, and you'll have to re-clone then from your remotes. Your working copy should still be present, so you can use that to recover any changes that weren't pushed to the server.

You cannot clone into a non-empty folder, so if you do this, you need to create new clones and overwrite the working copy with the current set of files.

This can also happen with latest SourceTree if git is reinstalled. Sadly SourceTree fails the ability to detect fit installed on /usr/local/bin/git -- which happens to be the default location for git when installed with homebrew on MacOS.

I have the same exact issue with Sourcetree and when I go to Tools\Options\Git under Git Version, the "System" button is grayed out. I was just trying it out to see if I liked it better than GitHub Desktop and it seems like it might be but it is so much more difficult to get setup correctly and I lost my patients with it.

I give up for now but if somebody is able to help me on here I will give it another chance.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

5,011 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you