Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why is Sourcetree taking 10+ minutes to open and then won't even work when it opens?

When I open Sourcetree, the blue 'Sourcetree' image pops up for ~1 second, and then disappears - the .exe process continues to run in the background, though, and it eventually opens ~10-20 minutes later. However, when it opens, it doesn't work properly - it just stalls and freezes and I can barely click on anything. This issue started when I was using a rev in 2.#.#, but I uninstalled that, then installed 3.0.8, and the same issue has not gone away... Please help.

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

7,107 views 5 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you