Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,849
Community Members
 
Community Events
168
Community Groups

Why does my sourcetree no longer detect uncommitted changes?

Hi hive mind,

Just yesterday my Sourcetree was working fine, but today the file status tab doesn't detect any pending changes. Similarly, the commit button doesn't show anything either.

I looked around and saw this has been an issue in the past, and I tried some of the solutions offered in old posts ("Disable LibGit2 Integration," get the latest update, restart computer). Nothing yet. I'm using 3.4.9 as of today, but the issue was the same on 3.4.8.

Does anyone out there have any experience with this or other directions to offer?

1 answer

0 votes
Pramodh M Community Leader Aug 26, 2022

Probably it is because of the reported bug here https://jira.atlassian.com/browse/SRCTREEWIN-7112

Manually commit the changes using git commands and push the changes to the repo if you need the code changes you have made

The bug doesn't have workaround or any other suggestion and disbaling libgit2 has worked for most of them, so trying it on new repo might work

Try to clone a new repo and see if it detects the changes

Thanks

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

78,667 views 134 29
Read article

Atlassian Community Events