Unable to select Beyond Compare as "External Diff Tool" to make external diff work

I use Beyond Compare 4 as my External Diff comparison tool.

I selected it from the Dropdown list, but it does not seem to work. Perhaps the dropdown is based on an older version?

I also couldn't use a Custom > Diff Command unless I used c:\progra~1 instead of c:\program files. I tried wrapping c:\program files in double quotes, but that didn't make a difference.

The program location is: C:\Program Files\Beyond Compare 4\BCompare.exe

I had to configure Custom as c:\progra~1\beyond~1\bcompare.exe to make the external diff to work.

Not intuitive.

 Couldn't upload and attach image (HTTP error), so I am providing a link from imgur: http://i.imgur.com/XZB46F5.jpg

 

1 answer

I'm having problems also – Windows 7, SourceTree 1.8.2.3, Beyond Compare 4

I tried the suggestion above - using c:\progra~1\beyond~1\BCompare.exe, but that doesn't work for me. 

Why doesn't the standard "Beyond Compare" from the External diff tool pulldown just work? Why do we need to do the Custom setup at all?? 

 

Very frustrating. 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

829 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you