Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,493
Community Members
 
Community Events
176
Community Groups

Unable to commit using App Password in SourceTree

I have created app password with all permissions. In SourceTree, Tools -> Options -> Authentication tab shows Authentication: OK. When I try to push it shows me an authentication error.

remote: Bitbucket Cloud recently stopped supporting account passwords for Git authentication.
remote: See our community post for more details: https://atlassian.community/t5/x/x/ba-p/1948231
remote: App passwords are recommended for most use cases and can be created in your Personal settings:
remote: https://bitbucket.org/account/settings/app-passwords/
fatal: Authentication failed for 'https://bitbucket.org/mrunmayeeshirodkar/typs.git/'

 

What am I missing?

 

9 answers

I got the same issue from now and then, mostly Source Tree password cache problem.

This fixed my issue:

(1) Clean Window Credentials

  1. First close any open instances of SourceTree
  2. Go to Control Panel > User Accounts > Manage Credentials > Windows Credentials
  3. Find SourceTree related passwords and remove them

(2) Clean Source Tree "passwd" file

  1. Open Windows Explorer (⊞ Win+E)
  2. In the address bar, go to "%LocalAppData%/Atlassian/SourceTree"
  3. Delete "passwd" file
  4. Open Source Tree and Perform a Fetch before doing anything else.


Ref: stackoverflow.com/questions/45690641/

Worked!!! Thanks.... Life saver... :)

This worked - many thanks!

Thank you so much. This worked like a charm.

I had a similar problem trying to clone a repository. These steps helped me to solve it. Thank you very much!

This fixed it when nothing else would, thank you!  For others/SEO, my original issue was not seeing remote repositories, then when Atlassian updated the credential system I was no longer able to commit existing repos with the old OAuth system or the new app passwords.  At all times the settings screen showed a green check for authentication.  The above fixed all the issues.

Wonderful!

It worked magically without knowing all the details behind.

Thank you very much for saving my time.

You are a wonderful person! :) Thank you for saving a battle, and maybe losing a bunch of my project! :)

Awesome, worked. For me, it was sufficient to delete the passwd-file and perform a fetch.

Was having the same issue, my friend was able to find a solution after lots of tries and now it's working. 

 

First, download and install Git in your system, if you don't have it. https://git-scm.com/

 

Then, go to Tools > Options > Git and select System, as seen here:

Captură_ecran_030222_121156_PM.jpg

Login again with the new App password when prompted and everything should work well. You can also try Update Embedded option too, maybe it will fix it without the need of System use.

Many thanks for this, this solved my issue.

Like Razvan Grigore likes this

thats my first comment at this forum only to say, thanks man, you saved me.

Like Razvan Grigore likes this

thank you !! worked like charm

Like Razvan Grigore likes this

Thank you.  What an annoying issue...  This installation of git solution worked for me.

Like Razvan Grigore likes this

I've spent much of the day fighting with this problem, there is still no solution?

For me this wasn't resolved until I edited my Windows/System32/drivers/etc/hosts file to add

18.205.93.0 bitbucket.org

to the end of the file and save. 

 

Then it worked. Thanks to: https://www.youtube.com/watch?v=N2_EzkDZmBw

Bitbucket fucked up badly changin things that were actually working.

i have the same issues .it still in error. how can i solve this?

Mine is working properly now! I just deleted the existing credentials on my mac from by following this:

How to wipe Sourcetree preferences 

After deleting those files. Open your sourcetree again and for Mac a pop up box appeared and you have to enter your username and your app password and you should be good!

I have the same problem, today I tried to pull and push new commits but the system all the time said me:

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://yeissonh@bitbucket.org/**************
Output:
Error: remote: Bitbucket Cloud recently stopped supporting account passwords for Git authentication.
remote: See our community post for more details: https://atlassian.community/t5/x/x/ba-p/1948231
remote: App passwords are recommended for most use cases and can be created in your Personal settings:
remote: https://bitbucket.org/account/settings/app-passwords/
fatal: Authentication failed for 'https://bitbucket.org/*********

I try to delete the files and recreate the repository but nothing worked. 

Hi!

I resolved in this form:

I created SSH Key, I used this article:

Set up an SSH key | Bitbucket Cloud | Atlassian Support

And clone one more time

regards,

Like Dave Hughes likes this

I have the same issue. I have set it up and followed the instructions and still authentication error!! 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events