Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,847
Community Members
 
Community Events
168
Community Groups

Subtree Dissappears After Close and Open Sourcetree

Edited

Hello,

I am creating successfully a subtree to a remote repo and pull/push successfully. It appears under the "Stashed" tab on the left

However, when I close and reopen the Sourcetree, the subtree that I have defined earlier, disappears.

It does not disappear, if I close the project tab and reopen the project without closing the Sourcetree.

I have seen these two post with the same problem:

Link1

Link2

Both links belong to the same person.

I have tried the suggested solution there (clearing cache) but it did not solve my problem.

The person, who stated that he was in charge of developing this part of the Sourcetree, has not posted since 2017. Maybe he left Atlassian and these issues are still there.

Baris

2 answers

1 accepted

0 votes
Answer accepted

I found out that this is consequence of another major issue with Sourcetree versions came after 3.2.6. After this version, a major bug is introduced, probably something related to authentication, and it results a constant red exclamation mark on the remote button. This mark can be fixed in version 3.2.6, but not in the later versions. So, I am staying with version 3.2.6 for now.

Could anybody help me with this issue? 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events