Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Sourcetree losing track of tracked branches?

Luke Noel-Storr
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 13, 2019

Not sure if this is a bug.

Whenever I go to push or pull, Sourcetree no longer has the tracked branch selected to push to/pull from. Indeed, when I go to pull, it doesn't even have any branches available to pick from, until I hit refresh.

This is happening across all my repositories, whether hosted on github or gitlab.

I've tried changing the tracked branches, and then changing back, and still no luck.

Is this a bug? is there something else I can try?

1 answer

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 13, 2019

Hi @Luke Noel-Storr,

This isn't intentional. Please file a ticket (Mac, Windows) with details on your environment and what's happening so we can triage further there. Thanks for the report!

Brian Ganninger
Principal Developer, Sourcetree

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events