Sourcetree for Windows not updating remote repository state

Manual update doesn't appear to do anything. If I fetch changes, the new commits do show, but the branch isn't displayed as behind, (e.g. "master 7 behind").

The Mac client displays the same repository correctly when I open it from an SMB share.

Any ideas before I file a bug?

Thanks

1 answer

1 accepted

0 votes
Accepted answer

The Mac version automatically fetches in the background every X minutes (default 10), this isn't implemented in Windows yet so you have to Fetch manually. The push/pull icons also don't have the ahead/behind markers yet on Windows, although the branch label should have. Looks like they're displaying 'ahead' but not 'behind' correctly. Logged: https://jira.atlassian.com/browse/SRCTREEWIN-497

Thanks very much, Steve. I'll look forward to 9.1.2 with the fix.

While I was fixing it I also noticed that I'd written some code to put annotations on the sidebar for ahead/behind but they'd never been activated. So 0.9.1.2 will do this too:

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

828 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you