Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,023
Community Members
 
Community Events
176
Community Groups

Sourcetree crashes on startup

I installed Sourcetree the other day on a new work computer and it was working fine, then after the weekend it appears to be crashing on startup. The splash window with the logo and title appears briefly, then it closes.  Now after reinstalling it has the same behavior, splash window and then close. It does extract the files to AppData but doesn't open the installation wizard, and still doesn't open at all.  I tried everything I can think of up to digging into the registry for sourcetree and atlassian leftovers, any fix I could find for KERNELBASE.dll and every other solution on this forum, but nothing I do seems to work.

Event viewer error:

Faulting application name: SourceTree.exe, version: 3.4.8.0, time stamp: 0x5fd0b86e
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1566, time stamp: 0x0833f2d4
Exception code: 0xe0434352
Fault offset: 0x0000000000034f69
Faulting process id: 0x3f24
Faulting application start time: 0x01d83919366b6a41
Faulting application path: C:\Users\me\AppData\Local\SourceTree\app-3.4.0\SourceTree.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: 11d6beab-08f1-43bd-a41e-211d6579a14b
Faulting package full name:
Faulting package-relative application ID:

1 answer

0 votes
Vipin Yadav Atlassian Team Mar 16, 2022

Hi, 

Please try to uninstall and then reinstall Sourectree.

  1. Uninstall Sourcetree using the Windows Uninstall program.
  2.  Delete the folders/files below before proceeding to the next step:
    • Navigate to C:\Users\<UserName>\AppData\Local and delete all Sourcetree folders and files (if any)
    • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all Sourcetree folders and files (if any)
    • Navigate to C:\Users\<UserName>\AppData\Roaming\Atlassian and delete all Sourcetree folders and files (if any)
    • Navigate to C:\Users\<UserName>\AppData\Local\SourceTree-Settings and delete all Sourcetree folders and files (if any)

Download Sourcetree for Windows and install it

Let's see it works after this or not. 
if not then find the log file and send it here from below path.

C:\Users\<UserName>\AppData\Local\Atlassian\Sourcetree\sourcetree.log

Hi, thanks for your reply. 

I already deleted those folders several times after each uninstall during my attempts to make it work. 

Downloaded the launcher again each time too, and the install does the exact same as trying to open it, briefly shows the Sourcetree blue window with the logo, then closes without ever displaying any window, it doesn't even show on the taskbar. 

Installing does set the files on AppData/Local/SourceTree but neither opens the install wizard, creates an Atlassian folder in either Local or Roaming nor any visible logs on the install folder. It also doesn't create anything in Atlassian or SourceTree-Settings.

I also tried different, older versions of the install file and none work either. The KERNELBASE.dll error I get from the windows event viewer is the only thing I got.

Vipin Yadav Atlassian Team Mar 20, 2022

It's strange. Could you please check that Sourcetree is provided all the access rights. It happens when corporate policies restrict Sourcetree to access these folders and then it does not create these and sourcetree try to access them on startup. 
Also please let us know which windows version is used and Sourcetree 3.4.8 is used now .Net framework 4.8 (upgraded into only this version of sourcetree). 

I couldn't find anything that would suggest Sourcetree not having access rights. Asked our systems guys and they told me there's nothing that's being limited regarding instalations or folder access, since our team needs to install several different apps so they leave it up to our judgement.

My windows info is 
Windows 10 Pro 21H1
Windows Feature Experience Pack 120.2212.4170.0

And I just made sure I had .NET framework 4.8 installed.

It's so weird because it did work fine when I first installed in this machine, but it just stopped from friday to next monday. I don't recall installing anything and nobody else uses this computer.

I have the same issue. Reinstalling didn't work for me either. I tried with a different user profile and got the same behavior.

I did could fix it repairing the WMI registry following the steps of following link: Rebuilding the WMI Repository - Windows Forum - Spiceworks

I founded it in community product question: SourceTree crashes on launch (atlassian.com)

I hope it help you too...

I'm having the exact issues that bgman is having. Splash screen appears for one second then disappears. Same .NET and KERNALBASE.dll errors in my event viewer. Bgman did you ever find a solution to your problem? Thank you

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events