Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Sourcetree commit doesn't work

After installing Sourcetree on a new laptop, I'm unable to commit. If i press the commit button on the bottom right, i get the "User Information" pop-up. After pressing "OK" nothing happens. The commit button on the top left shows changes. When i press it, nothing happens.

Some details and observations: 

* We use a standalone Bitbucket server

* I'm able to clone repos from the bitbucket server and move between branches.

* The commit doesn't work with any of the buttons (top left, bottom right or the drop down menu)

* I'm able to commit using the terminal window

* After commuting using the terminal window, I'm able to push using the Sourcetree   button 

* Tried to install 3 different versions of Sourcetree (3.3.9, 3.3.8, 3.1.2), removing the AppData folder before a new installation. Wasn't able to commit with any version. 

* Tried using the embedded Git, as well as a standalone version


Has anyone experienced a similar issue? 

Any thoughts on what else i can try to pinpoint the issue?



2 answers

Unchecking the "Set global author details for Git and Mercurial" checkbox before OKing the "User information" popup solved the issue for me. I had to uncheck it, press OK, and then commit again. Did that once and now it commits every time.


Thank you! 1 day of trying everything and then finally found your comment. worked!!!!!

Like # people like this

I'm having the same issue. What does unchecking "Set global author details for Git and Mercurial" do? I haven't tried this yet, because I'm always overly cautious about changing things when I don't know what the effect will be. Thanks!

Like Aaron Johnson likes this


Same as above.

Any answer?

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events