Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,981
Community Members
 
Community Events
168
Community Groups

Sourcetree Clone error: Too many invalid password attempts.

Edited

Up till today I have always connected Sourcetree via Basic/HTTPS without any problems.

Today I had to change my password on id.atlassian.com. When I updated Sourcetree to use the new pass it said it was invalid. Have tried 3 times and Sourcetree always rejects the password.

If I use OAuth/HTTPS I can connect Sourcetree and see all repos. But when I try to clone, commit or push I get: 

remote: Too many invalid password attempts. Log in at https://id.atlassian.com/ to restore access.

fatal: unable to access 'https://bitbucket.org/*removed*/*removed*.git/': The requested URL returned error: 403

I have read through the last 2-3 years worth of posts here about this issue but none seem to help.

I have tried logging out of bitbucket.com and relogging in multiple times, but get the same error each time. I even found a keychain name bitbucket and deleted it, but that didn't help either. When I view my active sessions I see between 1 and 4 sessions, depending on when I've looked - all appear to be my IP and Chrome. 

I don't understand why Basic no longer connects with the correct user/pass, or why OAuth "works" as far as connecting Sourcetree, but won't let me clone/commit/push anything.

I'm on a Mac (BigSur 11.3.1).

Update 6/6/21: 

I've now also tried setting up an App Password following the instructions here: https://support.atlassian.com/bitbucket-cloud/docs/app-passwords/

...which appears to let me connect to bitbucket through Sourcetree (like OAuth did) but still gives the same 403 error when trying to clone/push/pull.

Any ideas?

 

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

78,689 views 134 29
Read article

Atlassian Community Events