SourceTree is now crashing on startup v.2.0.5.6 on OS X 10.8

I've rebooted, reinstalled and tried again but since SourceTree was updated yesterday it now won't launch at all. Here's the crash report:

 

Process:         SourceTree [592]
Path:            /Applications/SourceTree.app/Contents/MacOS/SourceTree
Identifier:      com.torusknot.SourceTreeNotMAS
Version:         2.0.5.6 (2.0.5.6)
Code Type:       X86-64 (Native)
Parent Process:  launchd [314]
User ID:         501
Date/Time:       2015-11-18 09:17:35.542 +0000
OS Version:      Mac OS X 10.8.5 (12F2560)
Report Version:  10
Interval Since Last Report:          4667 sec
Crashes Since Last Report:           213
Per-App Interval Since Last Report:  132 sec
Per-App Crashes Since Last Report:   6
Anonymous UUID:                      B34695F2-A3EB-37B1-951A-A26E89592103
Crashed Thread:  8  Dispatch queue: com.apple.root.high-priority
Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000038
VM Regions Near 0x38:
--> 
    __TEXT                 0000000109646000-0000000109904000 [ 2808K] r-x/rwx SM=COW  /Applications/SourceTree.app/Contents/MacOS/SourceTree
Thread 0:: Dispatch queue: com.apple.main-thread

I've just now realised I have version 2.0.5.5 on my Yosemite partition and copied it over so it's all working again but there's clearly a showstopper bug in 2.0.5.6 for Mountain Lion users.

EDIT: I did paste the crash report above but my post was rejected for blacklisted words so...

27 answers

Same here, v2.0.5.6 on OSX 10.9.5 crashes at startup. I've tried:

  • removing saved application state (there wasn't any)
  • removing the application support folder for ST
  • removing the preferences plist

None of them helped.

I even tried to disassemble the binary with Hopper, but I didn't manage to find the address of the function that caused the crash, according to this callstack:

Thread 10 Crashed:: Dispatch queue: com.apple.root.high-priority
0   libdispatch.dylib                 0x00007fff87829eeb dispatch_async_f + 3
1   com.torusknot.SourceTreeNotMAS    0x00000001008de732 0x1006f0000 + 2025266
2   com.torusknot.SourceTreeNotMAS    0x00000001008de678 0x1006f0000 + 2025080
3   libdispatch.dylib                 0x00007fff8782728d _dispatch_client_callout + 8
4   libdispatch.dylib                 0x00007fff87829885 _dispatch_source_invoke + 413
5   libdispatch.dylib                 0x00007fff87828f87 _dispatch_root_queue_drain + 75
6   libdispatch.dylib                 0x00007fff8782a177 _dispatch_worker_thread2 + 40
7   libsystem_pthread.dylib           0x00007fff884a5ef8 _pthread_wqthread + 314
8   libsystem_pthread.dylib           0x00007fff884a8fb9 start_wqthread + 13

Hoping for a quick fix ASAP.

2 votes
Andrew Er Atlassian Team Nov 20, 2015

Hi Everyone! Thanks for raising your concerns.

Yes, this is true, this is a known bug from this public issue on OS X. Please be sure to watch it, and vote on it, so that you're notified if this bug will be fixed in a future release.

For your reference, you can find our policy on how we prioritise feature and improvement requests at this page.

As for now, the workaround is to Wipe of SourceTree's Preference and restart SourceTree. Ensure that you have make a backup of the entire directory before doing so if needed. There is another alternative which is that you can download the previous version - SourceTree 2.0.5.5.

Hope that answers everyone's question! Please feel free to raise a ticket should you have any questions!

Thanks for pointing out the ticket. Looks like it'll be fixed in 2.0.5.7. That prioritization of features policy page gives me a 404 error. Is the DEV space not publicly accessible?

The suggested workaround, wipe of sourcetree's preferences, does not work. Version 2.0.5.7 still crashes and a number of occasions and after a certain amount of time. Going back to 2.0.5.5 is a workaround, however.

Ditto for me, still crashing w 2.0.5.7

I'm experiencing the same problem here with OS X 10.9.5.

Same here. Crashes after upgrade to v2.0.5.6 on OS X 10.9.5.

Same here, also on 10.9.5.

Me too, frequent crashes with v2.0.5.6 and OS X 10.11.1

Same problem on 10.9.5. I've removed settings in ~/Library/, but it not helps.

Same here; crashing after upgrate to v2.0.5.6 with OS X 10.9.5; downgraded to 2.0.5.5 to get going again.

Same here, constantly crash on startup running latest Mavericks. On ElCapitan every first start is crashing, second try works…

Anybody there? It seems this might be a widespread bug. Probably a good idea to pull the update if you can't get a fix out promptly. Maybe ask for some crash reports if you can't replicate it.

Same problem here, and after the 1st crash, computer keeps freezing every 15secs or so. I'm on 10.9.5.

Same; just upgraded to El Capitain & as Sebastian said, then it works with the second launch

Same here - has anyone opened a support case with Atlassian?

Same - Mac 10.9.5 - I have copied over the new version of Sourcetree with a backup of the previous version and it's running again.

Crashing every time I launch it in 10.11.1. Yesterday it crashed a couple of times, but then I could launch it and use it. Not as lucky today.

I just started getting crashes at startup with v2.0.5.6 on OSX 10.9.5. I regressed to 2.0.5.5 as per previous comment from Andrew Er and that seems to have 'fixed' it inasmuch as i can now use ST again. So a +1 for that and thanks, was frustrating.

0 vote
Andrew Er Atlassian Team Nov 23, 2015

 

Hi Powellian! Glad that helped!

Just to let everyone know that SourceTree 2.0.5.7 is available to download which has contained the fix.

2.0.5.7 still crashes for me.

Ich just downloaded 2.0.5.7 from the above link. Still crashes on 10.9.5. I tried nothing else.

EDIT:

Copied version 2.0.5.5 over lastly installed 2.0.5.7. Startup without crash. Then updated from within 2.0.5.5. Now 2.0.5.7 works without crash on startup.

Exactly the same experience as Pete. Updated to 2.0.5.7 - crashed. Copied over 2.0.5.5, crashed again. Second attempt it launched. Updated again to 2.0.5.7 and this time it's working. I wouldn't have tried again though had I not read Pete's message so just re-iterating that this approach may work for others.

Same here. I'm running OS X 0.9.5 and I found SourceTree crashed at launch. Upgrading to 2.0.5.7. A reboot did not help. Reverting to 2.0.5.5 fixed it.

I spoke too soon. Was just reading the last answer and ST suddenly quit, now it won't relaunch without crashing again. Back to 2.0.5.5.

I didn't trust the auto-updater, so I renamed 2.0.5.5 (SourceTree Stable) and installed 2.0.5.7 alongside it.  The new version does not crash right after launch for me now, so that's good.  I hope it stays that way!

Update: I spoke too soon. After quitting once, it once again crashes almost immediately, just like 2.0.5.6 did, every time I try launching it again.  2.0.5.5 is still working fine, so I'm back to that release.

I had 2.0.5.6 but updated to 2.0.5.7 but still keeps crashing on my OS 10.11.1

2.0.5.7 still crashes randomly (OSX 10.11 15A284), sometimes when it's running for a few hours, sometimes immediately when I start it up.

Same here, 2.0.5.7 crashes randomly on 10.11.1 either on startup or with a delay

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

647 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you