Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

SourceTree does not launch


SourceTree for Windows is not launching for me starting today. There was no update done prior to me attempting to launch SourceTree.  However, it appears SourceTree is trying to perform an update as it is launching  A window pops up saying "Downloading file ... Downloading from"  This window goes away quickly, then nothing happens after that.

I checked the SourceTree.Log for today, and I see just this:

ERROR [2018-05-17 11:50:41,654] [1] [SourceTree.AppRoot+<OnStartup>d__33] [MoveNext] - Preflight checks failed! Continuing to run SourceTree



1 answer

1 accepted

0 votes
Answer accepted
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 17, 2018


There is a minor bug related to the download, it installs an authentication component for Mercurial usage and it currently runs too often, i.e. it should only run once and from then on detect that it has worked and not run again.

However that should not prevent Sourcetree from starting.

As you are seeing that popup Sourcetree is starting, but then apparently nothing after that. Is there nothing else in the log files?

There are a number of entries prior to today, but that is the only entry for today.

Also, a side note. The Atlassian Support web page suggests I download an update. But the link provided returns a 404:

Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 17, 2018

Can you tell me where you saw that URL? It points to a very old version, you can get the latest from

Technical issues and bugs

You will then see:

Get the latest Sourcetree bug fixes and improvements

with the option:

Download the latest version for Windows

Downloading the app (using your link) fixed my problem.

For me, it is still not launching.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events