SourceTree crashing on opening repositories after upgrade to 1.9.5

I upgraded to SourceTree 1.9.5 today, but it started to crash on every launch. I happened to have an old copy of 1.5.7 so I removed the new version and installed the old version in its place. I was then able to open repositories. I tried switching back to 1.9.5 (because maybe it was just corrupted user data or something) but then I was able to open the bookmark browser but not open any of the repositories. Every time I double-clicked on a repo it would try to open its window and crash.

I've attached the crash report. (sourcetree-crashlog-2014-07-08.txt)

8 answers

I upgraded today, and am crashing on open as well. Tried with both reopening existing repository windows as well as just opening the app on its own. I'm a little hesitant to delete all my preferences as that's a lot of projects to recreate. (sourcetree-1.9.5-crash-report.txt)

Same problem here. Sourcetree is crashing after upgraded to 1.9.5. The crash happens while the app is trying to display the bookmark window or restoring the previous. This is on OSX 10.7.5. I tried wiping the preferences but that didn't help (https://confluence.atlassian.com/display/SOURCETREEKB/Wiping+SourceTree+Preferences). Also tried downgrading to 1.9.4 and now the app windows are not even displayed.

Similar story here, repeated crashes when opening repositories either from the Bookmarks window or from the File... Open Recent menu selections. I am also (stuck on) on OS X 10.7.5

(sourctree_crash.txt)

I'm in the exact same situation and my crashlog looks the same. I'm also stuck on 10.7.5 and can't upgrade due to business policies right now. How does one revert back to 1.9.4?

Hi - scroll to the bottom of this page for Atlassian's link to the 1.9.4.1 dmg:

https://jira.atlassian.com/browse/SRCTREE-2530

Sorry about this, we've been actively working on a fix since we were made aware of the problem yesterday. We'll be issuing a fix shortly, likely tomorrow for those 10.7.5 users affected.

Cheers

Hi Kieran. I've just installed 1.9.5 today (running on Windows 10) through the sourcetree automatic update and encountered this same bug. If you've known about this bug for more than two weeks why are you still pushing the bugged version which has made sourcetree completely unable to load?

And do you have any idea when you will actually get a fix out for this? I assume the reference to 10.7.5 is referring to an OSX fix rather than a windows fix?

Guys, trying running it as Administrator. :) That's how i got mine working.

Hi,

I had the same problem after upgrading to 1.9.5.0

Indeed, I have the problem (only) when I do a commit from the context menu.

Remember to update embedded Mercurial and git from Tools menu > Options (onglet Git & Mercurial)

Best,

Saad

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

262 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot