SourceTree 2.0: "Uncommitted changes" yet nothing is pending

I just updated SourceTree to version 2.0.20.1 and I'm seeing something weird. My repository is saying that there are uncommitted changes but nothing is pending. I've checked the files and saw no pending changes. I entered "git status" on the command line and received a message that my repo was up to date.

I have discarded the changes and did a reverse commit to try and get rid of these ghost uncommitted changes, but both attempts did not work. Has anyone else experienced this bug? How do I get SourceTree to not think there are uncommitted changes when nothing is pending?

I did not get this bug before I updated to SourceTree 2.0. While I was making this thread, there was one suggested thread that might have answers, but the suggestions in that thread did not work. Thread

st.jpg

5 answers

2 accepted

7 votes
Accepted answer

I found a solution.

I do not have files with case-sensitive names.

But: When i check "Disable LibGit2 integration", all "uncommited changes" disappear!

I feel that the overall operation has become faster.

Disabling LibGit2 integration worked for me. Tools: Options: Git: Disable LibGit2 integration.

Thanks for the tip!

Disabling LibGit2 (and then restarting Sourcetree) also fixed it for me.

Agreed, seems to run faster now too, not lagging on changing tabs with that scrolling progress indicator in the upper left.

Disabling LibGit2 integration (with restart) worked for me too.

Thanks!

This worked for me too. Is there any downside to this?

Thanks!

v2.3.1.0 Worked for me after SourceTree restart. Thank you.

2 votes
Accepted answer

Hi Matthew! This has been reported as a bug, you can find it at SRCTREEWIN-7112. There's no workaround for it at the moment, please watch that ticket so you get notified of further updates. Let me know if you have any other questions :)

Kind regards,

Ana

Thanks, Ana!

To be clear, to continue working on the repositories will not cause an issue in terms of data corruption?

I fixed this with the Git mv command... and correct the file with the correct filename. 

Command:

Git mv -f [SourceRepositoryLocation/WrongFileName] [DestinationRepositoryLocation/RightFileName]

I then just did a commit to the branch and the "Uncommited changes" node disappeared. 

As per today, if I go to Tools: Options: Git: Disable LibGit2 integration, and check "Disable LibGit2 integration" then the ghost uncommitted changes INSTANTLY go away.

then, they don't reappear if I enable it again, even without closing that dialog.

BUT

if I close SourceTree with LibGit2 still enabled (unchecked) and launch it again, the uncommitted changes pop back again.

Is it normal to have such issues? I was pretty surprised to see such an astounding bug still around (2017-10-31)

0 votes

As of 24 AUG 2018, the bug is still there. I created a new repo, but could not commit any local changes to my remote until after I disabled LibGit2 integration. Until I did that, NOTHING happened. I'd say this is a show-stopper that should have been corrected a year ago.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

968 views 4 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you