Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,193
Community Members
 
Community Events
168
Community Groups

Something is totally messed up with login

Edited

Bitbucket account, logs in fine in Bitbucket, Sourcetree refuses to accept password, keeps prompting.  There's some kind of big disconnect, and I cannot figure out how to fix it.

 

Also, I'm already logged into Bitbucket, why do I need to login again in Sourcetree at all?

1 answer

0 votes
bgannin Atlassian Team May 16, 2019

Hi @Michael Hylton,

A few questions:

- What version of Sourcetree are you using?
- What platform are you on?
- If you remove and re-add the account does the problem persist?

Cheers,

Brian Ganninger
Principal Developer, Sourcetree

Hi Brian,

-    Version 3.1.2
-    Win 64

-    Tried that and uninstalling Sourcetree and reinstalling.

The problem all started when I couldn't remember my password to Bitbucket a few weeks back, and I wound up changing it.  After that, I couldn't "login" to Sourcetree.

 

Hope this helps,

Michael

bgannin Atlassian Team May 16, 2019

Uninstalling the app doesn't affect the stored settings. You'll want to remove and re-add via Options -> Accounts and see if the problem still exists.

Thanks Brian.  I've tried removing all account in SourceTree, I've tried disconnecting BitBucket from SourceTree and starting over.  Nothing seems to work.  I have confirmed that I can perform the git clone command using a windows command prompt.  It too prompts me for the password, and it accepted it and brought down the code per the norm.   I'm not sure what is going on with my account as it relates to Bitbucket and SourceTree, but something there is amiss.

 

Michael

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events