Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Python error adding new repository

I'm new to Sourcetree, and I'm trying to open up an existing Mercurial repository. In the main window, I get this error message:

env: python: No such file or directory

I do have Python installed and working. Why is Sourcetree not finding it?

grahamb@pickle:~/Work/repo/dev$ which python
/usr/bin/python
grahamb@pickle:~/Work/repo/dev$ which env
/usr/bin/env
grahamb@pickle:~/Work/repo/dev$ env python
Python 2.6.1 (r261:67515, Aug  2 2010, 20:10:18) 
[GCC 4.2.1 (Apple Inc. build 5646)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

Screenshot

4 answers

1 accepted

0 votes
Answer accepted

Problem solved! I had in the dim and distant past, installed an Environment Variables plugin to the System Preferences tool. I hadn't realised that adding to my PATH in here was a bad idea. (It edits my environment.plist file, which is apparently where GUI apps get their environment settings from.)

I had also set the path correctly in my .bash_profile, which is why 'env' and 'python' worked fine in the terminal.

Solved by removing the PATH entry from environment.plist. Sourcetree now runs just fine without my local edits.

Awesome, that explains everything. Thanks for letting us know!

@Graham Borland1  @stevestreeting Can you elaborate this answer please as I am not getting any environment.plist file.

I am using Mac OS Catalina 10.15.4 and I am having problems with source tree as I am getting the same error as you.

That's the standard Python location (it's where mine is) so this should work, however on the Mac the PATH is different for apps than it is for the console, perhaps yours has changed so that /usr/bin is not on it.

The PATH for Mac apps is derived from 2 places (and not the PATH variable):

  • /etc/paths
  • /etc/paths.d/*

So to determine what paths are present for apps, you should do this:

cat /etc/paths
find /etc/paths.d/* -exec cat {} \;

For example, mine looks like this:

Steves-Mac:~ steve$ cat /etc/paths
/usr/bin
/bin
/usr/sbin
/sbin
/usr/local/bin
Steves-Mac:~ steve$ find /etc/paths.d/* -exec cat {} \;
/usr/local/MacGPG2/bin
/usr/X11/bin
/usr/local/git/bin

Thanks, but /usr/bin is present in /etc/paths. Any more suggestions?

If you run the below on the command line, what do you get?

/usr/bin/env python

This is the command at the top of the 'hg' script which appears to be failing in your case, although I've never heard of that before.

I get exactly the same Python output as I posted in the question.

Doh, sorry I missed that.

I'm at a loss, if env and python are on your /etc/paths this should work. I'd quite like to see a screenshot of the error in case that helps.

Also, have you changed which Mercurial you're using in Preferences (if you have Mercurial installed separately)?

Screenshot uploaded. I haven't changed any options from the default. I tried resetting to the embedded Mercurial, just to be safe, but that has no effect. I do have hg installed in /usr/local/bin via Homebrew, but Sourcetree can't find that one since it's not in the app path.

I also just noticed that the Sourcetree icon in my Applications folder still has a 0 overlaid, as if it hasn't been fully installed or activated. During setup, I did allow permission for the app to modify my global settings files.

Firstly, the reason ST can't find your system hg will be because /usr/local/bin isn't in your /etc/paths or /etc/paths.d - ST will find a system hg anywhere so long as it's on the path (for apps, not the console). The trouble with Homebrew is that it installs things in unusual locations and doesn't recognise the existence of anything other than terminals, so you have to tweak things manually if you want GUI apps to pick things up. If you use the standard Mercurial install it'll work out of the box, although Mercurial 1.9 is not supported yet because of a merge crash bug on OS X (this is queued for 1.9.3, I submitted a patch).

About the '0' on the app, this suggests there might be a remaining permissions problem - did you install SourceTree as another user, or in some way that might leave your current user unable to access all of it?

I just removed and then re-installted, with exactly the same results. I also get exactly the same result if I run the app directly from the downloaded disk image.

I'll try installing hg to a standard location and see if that helps.

OK, thanks for trying things - you shouldn't have to though, I test on machines that have never had hg/git installed and it's normally fine.

I'm glad you resolved it, but I have no idea why you needed to do that. Obviously I can't change that in the main package because it wouldn't work on machines where Python was somewhere else (rare, but possible). Using 'env' works for everyone else :/

I got it working by changing the hg_local script inside Sourcetree's app directory to call /usr/bin/python directly.

For anyone still looking into this, I solved the issue by telling SourceTree to use the system git, instead of the embedded one. Under "Preferences/git/Git Version".

@Pablo Diaz-Gutierrez I have the same but issue is not resolved.

I am using Mac OS Catalina 10.15.4.

I have attached screenshot in the top. Please check!!

Unfortunately I have since upgraded to the macOS 11 Big Sur (beta 8) and the problem is back with a vengeance. I'll try again later; right now I'm just using the command line for 99% of my git work.

Like akash_keshari likes this

@Pablo Diaz-Gutierrez Please try and let me know if there is any update for the fix.

Ok, I took another look and the new workaround is to edit the pre-commit hook file. So if you open `.git/hooks/pre-commit` or `.git/modules/SUBMODULENAME/hooks/pre-commit` in your repository, you see that it uses python3.8 in the first line. However, python3.8 lives on /usr/local/bin (the path that SourceTree ignores), whereas in /usr/bin (the path that SourceTree uses), I have python3.

Therefore, possible fixes:

- Replace python3.8 with python3 in the hook file (I did this), or

- Add the full path to python3.8, as in /usr/local/bin/python3.8

Like akash_keshari likes this

@Pablo Diaz-Gutierrez  Both the fixes are working fine. 

Awesome Pablo, Thanks a lot...

I wonder how you can able to debug this and find out the fix, it would be a lot helpful if you can explain that, it would really enhance my debugging skills. ☺️

Like Pablo Diaz-Gutierrez likes this

I just looked for mentions of "python3.8" in all my .git folder structure, found that one, and started fiddling around, looking for ways in which that I could modify the script to make things work.

Good luck!

Like akash_keshari likes this

Nice to hear that... Thanks again..

 

Good luck to you as well.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

2,408 views 4 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you