Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Pulling a certain remote repository deletes the target folder upon connection closue

hello everyone I am trying to clone a specific remote project, when I do I get the following error logs :

git -c filter.lfs.smudge= -c filter.lfs.required=false -c diff.mnemonicprefix=false -c core.quotepath=false clone --recursive https:/ "C:\Users\profile\Documents\QAPRoject"
Cloning into 'C:\Users\profile\Documents\QAPRoject'...
warning: templates not found C:\Users\profile\AppData\Local\Atlassian\SourceTree\git_local\share\git-core\templates
fatal: The remote end hung up unexpectedly
fatal: protocol error: bad pack header
error: RPC failed; curl 18 transfer closed with outstanding read data remaining
Completed with errors, see above.


However most confusing is that upon pulling this project and when it is canceled it deletes whatever .git file it was constructing AS WELL AS the head folder the project was being targeted to be placed in . it's a bizarre situation. 

I tried pulling other remote repositories as well ( from cloud forge) and they worked fine but this one specifically is causing issues.  


Does anyone have advice or suggestions on what exactly is going on here?


I've included screenshots of the project in the midst of downloading and its targeted folders, after downloading, and then with the windows explorer being forced up a level because the targeted folder was removed.  


 For what it's worth I have tried pulling this project down on both Mac AND Windows computers and both have the same result, on the windows machine it was at least closing and the folders held nothing more than a small . git  file .

Screenshot (311).pngScreenshot (312).pngScreenshot (313).png

0 answers

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events