Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Please enter the user details you wish to associate with your comments

This dialog pops up continuously rendering the app unusable. The details are filled out and `Use details for all repositories` is checked. Going into settings everything is filled out. You cannot dismiss this modal dialog by clicking ok.

It is impossible to use sourcetree at all in this state.

Command line git seems to function fine. This is a major bug rendering this software useless.

 

 

5 answers

3 votes
Ana Retamal Atlassian Team Mar 13, 2018

 

Hi Chuck! I've seen that you've already added your comment on the bug report at SRCTREEWIN-6511.

Have you tried some of the solutions provided by the users? One of them was able to resolve this problem by selecting Repository > Repository Settings and unchecking the Use global user settings checkbox on the Advanced page. Changing git from cygwin git to the embedded version seemed to solve the problem for another one. 

You can also try a clean install by following the steps:

  1. Wipe Sourcetree preferences.
  2. Uninstall Sourcetree (if it shows on the App&Features list)
  3. Backup then delete the directory below before proceeding with next step:
    • On Windows:
      • Navigate to C:\Users\<UserName>\AppData\Local and delete Sourcetree & Sourcetree-Settings folder
      • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all Sourcetree Files/ folder.
    • On Mac:
      • ~/Library/Application Support/SourceTree
  4. Download SourceTree and install it.

One of our developers also posted some questions to help with the troubleshooting of the issue, but nobody replied so far, could you provide the answer to the following:

  1. If you go into Tools/Options/General and fill in the Default User Details does that fix the problem?
  2. If you switch to using the latest embedded version of Git, in Tools/Options/Git tab, does that fix the problem?
  3. What version of Git you are using, and is it a system install or the embedded one?
  4. Which OS and Sourcetree version are you using?

Best regards!

Ana

This is the latest version for windows. None of these suggestions fix the problem. As someone noted, it has something to do with the HOME environment variable.

Try using sourcetree on a windows machine with no HOME defined and you will see how intrusive this bug becomes.

Ok, Chuck.

I've just had the same problem. I fixed it by SELECTING all staged files and then clicking commit

Like # people like this

I'm having the same issue.  Selecting the staged files does not work.  using version 2.6.10.0 on Windows 10. I have no idea if it's a system install or an embedded install.

I can confirm that defining a new environment variable called HOME and pointing it at my user directory, then restarting Source Tree fixed the problem for me.

Like CarlOlsen likes this

I can confirm that adding the HOME environment variable and point it to my user home directory works. This fixes the problem.

The HOME trick worked for me too, thanks.

adding the HOME environment variable worked for me too

Wiping the Sourcetree preferences, and regenerating the Personal Access Token in ADO worked for me.  

I love the answers that are all snarky!
"did you hack out some of the shit that other people had to wade through to try and figure out how to make this piece of shit work properly?"

Awesome support.

"One person tried this thing and it worked and another person tried this other thing and that worked too!"

So comprehensive. It's like Atlassian goes out of their way to be as useless as possible.

I have solved the issue by committing all the changes through git bash. Now sourcetree is working as usual.

I got around this problem by clearing the checkbox for 'Allow Sourcetree to manage my credentials via the Git Credential Manager'.  This is in Tools->Options->GIT.

Sourcetree version 3.3.6

I followed below steps to resolve this issue:-

1. Open GIT terminal

2. Run "git status" command to see what's pending

3. Tried to commit files using "git commit -m "<your message goes here>" . This failed for the first time but I got directions. I found my user in the config file was somehow modified.

4. Ran " git config --global --edit" and modified my username, saved the config file 

5. Tried to commit files again using "git commit -m "<your message goes here>"

AND IT WORKED THIS TIME!

I opened SourceTree again and everything was working as expected.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,419 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you