Performance problems in Sourcetree when opening/closing a repository

Hi,

when I open (or close) a repository (e.g. from the bookmark list) Sourcetree sometimes takes about 10 to 30 seconds until it's "ready". This only happens when I've mounted SMB-Shares. It happens with remote and local cloned repositories. At that time Activity Monitor shows Sourcetree as "not responding" (red).

I'm using Sourcetree 1.6.1 on OS X 10.7.5.

Did you ever experience similar problems and do you have any hints/ideas to solve this?

Thanks a lot!

Regards,

Mirko

1 answer

1 accepted

We really don't recommend mounting repositories across SMB shares. Network latency undermines the speed of a DVCS and SMB itself is not a particularly robust protocol and has been known to cause repository corruptions in the event of connections being interrupted or parallel use.

So it might sound like a cop-out but my main suggestion to resolve this is to not use SMB - DVCS repositories are intended to be used locally.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

649 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you