Performance problems in Sourcetree when opening/closing a repository

Hi,

when I open (or close) a repository (e.g. from the bookmark list) Sourcetree sometimes takes about 10 to 30 seconds until it's "ready". This only happens when I've mounted SMB-Shares. It happens with remote and local cloned repositories. At that time Activity Monitor shows Sourcetree as "not responding" (red).

I'm using Sourcetree 1.6.1 on OS X 10.7.5.

Did you ever experience similar problems and do you have any hints/ideas to solve this?

Thanks a lot!

Regards,

Mirko

1 answer

1 accepted

Accepted Answer
0 votes

We really don't recommend mounting repositories across SMB shares. Network latency undermines the speed of a DVCS and SMB itself is not a particularly robust protocol and has been known to cause repository corruptions in the event of connections being interrupted or parallel use.

So it might sound like a cop-out but my main suggestion to resolve this is to not use SMB - DVCS repositories are intended to be used locally.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

999 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you