It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

OAuth "Authentication Successful" issue, can not access repos in Sourcetree 2.6.10 or install 3.3.8

I am having issues trying to log on using OAuth 

I did have 1.8 installed but uninstalled it to upgrade.
I am using Google Chrome Version 81.0.4044.92 (Official Build) (64-bit)

I am currently trying with 2.6.10 as it lets me install it (3.3.8 has OAuth during install does not work so can complete install)

After installing 2.6.10 it does not show any of my remote repo's. When adding an account via OAuth I click "Refresh OAuth token" and the page opened and I select my account then says "Authentication Successful, SourceTree has been successfully authenticated. You may now close this page." 
But in the "Edit Hosting Account" screen it says "Login failed, Resource removed"
Auth_success.jpg


I have tried removing all cookies, all chrome extensions and/or using OAuth in a guest window, no difference. 

in Chrome, before I was able to get this far, I would just keep getting a blank screen and  I would keep seeing this error in the console. 

"google:1 Uncaught TypeError: page.googleAuthCallback is not a function"
googleAuthCallback.jpgTo log onto this forum I kept seeing this above error but when I took the offending line of code and copy/pasted it into the Chrome console to run it again I was able to log on. 

2 answers

1 accepted

0 votes
Answer accepted

OK have solved the issue, after a number of hours/days playing around trying to get things working

Just installed GitHub Desktop, and now am back up and working.

Ok I have made some progression on getting OAuth working in Sourcetree, 

I have installed 3.2.6 and setup my account using basic authentication using my username and a App password generated from bitbucket will full permissions selected. I could not see my list of remote repos but unable to clone (would get an error "This is not a valid source path" then more detail in that "Error: remote: Invalid username or password, fatal: Authentication failed for 'https://grobschmit@bitbucket.org/......" ) 

Then when I go back into the accounts settings in Sourcetree, I can change my authentication from basic to OAuth and it sets correctly. 

But I still can not clone a remote repo

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,927 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you