Mac version won't show bookmarks screen

SourceTree was working fine for me until I set up a second user on my iMac. Now from both accounts, SourceTree won't open the bookmarks screen/window. The new / clone command also doesn't open a window. I've removed and reinstalled the app several times and also removed the data in the ~/Library area but nothing has helped. Is there a way to fix this?

5 answers

1 accepted

The app was not working properly on Lion. The latest version has a fix and upgrading the OSX version also solves the problem.

Kevin and Eric,

Actually, I tried to find here would be the Source Tree logs but did find it.

Thanks Eric for your console logs! I’ve searched about these exactly errors that you’ve received about it seems a very common Mac OS X message, nothing specific to SourceTree.

I’m looking into this and one important step to troubleshooting is testing into the old versions, then we can understand if it happens only to the newers versions.

Kevin and Eric could you guys test the SourceTree 1.8.1? It’ll be only for the test purpose to check if this issue happen on the 1.8.1 too.

Here the SourceTree 1.8.1 in Atlassian SourceTree official link:

Other thing important is what Mac OS X are you guys running? Maybe it’s a bug related to some OS version.

There is this a bug report on jira.atlassian.comabout some troubles on v1.9.4 could be related:

Could you guys test it and let me know how it goes? I want to help you to solve this issue.

Kind Regards,

Henrique Lechner

i'm on 10.7.5

i've gone back to 1.9.3 as that seems to work just fine. i did test out the 1.8.1 for you as well though and didn't run into any problem with that either.

i've been following the bug report as well. the 1.9.4 test app that was posted there seems to work as well but with some minor artifacts showing in the one of the list views.

thanks for your help.

Yes, according to the bug Henrique listed, there is a known problem with 1.9.4 on OSX 10.7. It should be fixed in the next release, or you can upgrade your OS to 10.8.

Thanks Eric to share the solution with us :)

I’ve added the comment on the bug report to help the developers based on your answers.

Feel free to add yourselves as watcher of the bug report them you can get notified when it updates.

And Kevin please don’t forget to return to us sharing if it works for you too and selecting the correctly answer for this question, it can be useful for other persons that face the same problem.

Cheers,

Henrique Lechner

Hi Kevin,

You’re right about the configurations on ~/Library that’ll be on each user on this location:

~/Library/Application Support/SourceTree

~/Library/Preferences/com.torusknot.SourceTree*

To better help you on this issue, I would ask you to check the SourceTree logs if there is no error related of this issue so I can further investigate it for you.

Kind Regards,

Henrique Lechner

Henrique, where are the logs located that I need to check?

Henrique, I updated to Mavricks and now the app is working.

Henrique, where are the logs located that I need to check?

i too am having the same problems as kevin. and have tried the same troubleshooting.

bookmarks window won't open. have tried trashing the ~/Library/Application Support/SourceTree and ~/Library/Preferences/com.torusknot.SourceTree* files and multiple reinstalls. checked and unchecked the "don't show bookmarks when starting" options. tried collecting all the windows to see if it was just off screen.

in addition to his problems i also don't have access to the recently opened menu. it shows up but nothing will open from there.

i'm not of the SourceTree logs but the console shows:

  • 6/10/14 11:25:07.325 PM SourceTree: kCGErrorIllegalArgument: CGSGetWindowPresenter
  • 6/10/14 11:25:07.325 PM SourceTree: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
  • 6/10/14 11:25:07.343 PM SourceTree: kCGErrorIllegalArgument: _CGSFindSharedWindow: WID 9018
  • 6/10/14 11:25:07.343 PM SourceTree: kCGErrorIllegalArgument: CGSOrderWindowListWithGroups: invalid window ID (9018)
  • 6/10/14 11:25:07.343 PM SourceTree: kCGErrorIllegalArgument: CGSOrderWindowList: NULL list pointer or empty list
when starting sourcetree up. nothing recent under the soucetree folder.
if there's something i need to do to get this to work, i'd like to know. i can work around the problems for now, but i really do like this tool.
thanks

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

421 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you