Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,779
Community Members
 
Community Events
176
Community Groups

When I pull, I get this window

1002.png

Even though I enter correct username and password, it keeps popping out. The pull doesn't complete, this is the error:

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch origin
fatal: HttpRequestException encountered.
An error occurred while sending the request.

remote: Invalid username or password.
fatal: Authentication failed

I am able to pull through command line, but not through the sourcetree interface. Please help!

3 answers

1 accepted

4 votes
Answer accepted

The problem is that SourceTree's embedded Git client comes with git-credential-manager v1.12, which no longer works with Github since they disabled TLS 1.1 on their site.  You need to get git-credential-manager v1.14.  Easiest way to do that is to install a current copy of the Git client separately, and then switch SourceTree over to use that ("system git") instead of its embedded client.  Alternatively, you can update git-credential-manager in your embedded client by replacing its files with the newest version from Microsoft.

(This text here because this site doesn't allow me to post the same message in multiple threads, even when it's the answer to all of them.)

Thank you, it worked! 

I tried downloading git-credential-manager v1.14 first, but then I couldn't manage to make SourceTree use it. So I updated git-credential-manager in my embedded client. 

Thank you very much! it worked

Thanks for this solution. Caused some frustration until I found this article.

The folks at https://www.sourcetreeapp.com/ should replace their download package to include the newer git-credential-manager v1.14. It's more than 7 months after this question was posted and I ran into this just yesterday.

Like # people like this

Hi, I am having the very same problem, only that I already had Credential thingy v.14, tried updating to v.18, problem persists.

Then I updated GIT.

Problem persists.

Tried changing from embeded to system, problem persists.

Tried updating embeded one, it wont finish updating because problem persists, which also spawns a dozen more login windows.

Also tried reseting all passwords,

updating sourcetree

and even reinstalling sourcetree.

Also tried removing all saved passwords, and guess what?

 

Yes

 

Problem persists.

Like Rob Minson likes this

Thank you, it worked.

This started happening to me.

It's infuriating how brittle auth is in SourceTree- to the point where for every person I teach git to I _tell them_ auth is hacky and we should set aside a few minutes to play with OAuth/Basic to get it to work. Still problems pop up once every month or so.

There are also GUI issues that go unresolved for years.

 

Oh well, guess it's finally time to try GitKraken!

Hello! Could you try the following:

  • Remove the account via the options screen
  • Try pulling again
  • Insert your username + password

 

If that doesn't work, try adding the GitHub account with OAuth:

  • Options > Accounts
  • Add a new account, but set "Authentication" to "OAuth"
  • Login, switch back to Sourcetree
  • Try pulling again

Thanks for the suggestion. I tried that, it didn't help, still have this login window popping up when I'm trying to pull

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events