Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,390
Community Members
 
Community Events
176
Community Groups

How to ignore a file from the preview?

Hi,

First, thanks very much for the work on SourceTree, I'm using it for years and love it.

Now, I think lot of developers work with lock files (for example, every users of npm or Yarn have that package.lock file!) and these are literally crashing ST as I guess it tries to do a diff of them which slow down the app massively and makes it almost unusable.

Of course these files have to be tracked as it's their purpose. So I can't just .gitignore them.

Is it possible to tell to ST to not preview them?

 

Thanks!

1 answer

1 accepted

0 votes
Answer accepted
bgannin Atlassian Team Nov 15, 2017

Screen Shot 2017-11-15 at 2.19.01 PM.png

Check out the Ignore File Patterns option in Diff settings. 

Hi Brian,

It's working fine thank you! However I noticed this filter is not applied on the stashes. So when you click on your stash, if it contains a big file, you're ending up with ST freezing as well.

This is not working for me... I added package-lock.json to the Ignore File Patterns field and restarted the app, but when I select the package-lock.json file in either staged or un-staged files, it still displays in the diff-compare / preview window...

 

Screen Shot 2018-12-02 at 2.57.58 PM.png

Have a look here: https://jira.atlassian.com/browse/SRCTREE-6205

It appears the spec for "Ignore File Patterns" has changed. Now you have to explicitly specify wildcards, e.g. `*package-lock.json` instead of `package-lock.json`.

Like Rathan Kumar likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events