Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,130
Community Members
 
Community Events
176
Community Groups

How to get the engine "node" to be compatible with this module?

Edited

When trying to make a commit through SourceTree I get an error that reads:

The engine "node" is incompatible with this module. Expected version "^14.16.1". Got "18.3.0"

 

When I run nvm current node -v I get v14.16.1

When I run nvm ls I do not even see 18.3.0

My guess here is that SourceTree is looking at the "system" node version.

 

I have this in .zshrc which I thought worked this nvm stuff out.

export NVM_DIR="$HOME/.nvm"
[ -s "$NVM_DIR/nvm.sh" ] && \. "$NVM_DIR/nvm.sh"

 

I also called which node and tried adding the result to my path without any change.

How do I tell SourceTree to look at a specific version of node to make commits?

I should add that I am able to commit on the command line and then use SourceTree to push.

 

If I bypass the commit hooks I am able to make a commit with SourceTree. Suboptimal to be sure. I would like to sort out how to get SourceTree to see the correct node version on commit. 

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events