How to delete a tag and push

I have tried right clicking on the tag in the Tags sidebar and selecting Delete <tag name>. I also tried clicking on the Tag nav icon and then Remove Tag. In both cases the tag remains at origin/master. In the command line I would do git push origin :<tag name>.

Thanks,

Michael

3 answers

I encountered this today - 2014-07-01 (v1.9.4.1). But this article implies it was fixed in 2012? I also found that it isn't possible to push a tag when you are moving it. The move occurs locally but no one else can see the change; their tags remain in the previous location.

Yes, at the moment deleting a remote tag is not exposed, I'll try to get this one into the next update: https://jira.atlassian.com/browse/SRCTREE-431

I added a comment back in July that this is still an issue. I've seen no response. Thought I'd try commenting on your "fix" comment. Maybe you'll see it. :-)

Wow, thanks for the prompt response. I only stumbled on SourceTree recently but I think it is great. How can this be free? Thanks!

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

274 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot