Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,201
Community Members
 
Community Events
168
Community Groups

How do I report this bug?

I tried to post this bug, but it told me I don't have permission to assign issues, or something like that.

 

I'm running MacOS 10.14.6.  I use Sourcetree with remote accounts on both Bitbucket and GitHub.  I recently needed to add a repository from GitHub.  The first problem I noticed was that I could not use the Remote Desktop to clone the repository from GitHub, in spite of carefully entering my GitHub username and password.  It said it couldn't authenticate.  I tried adding my GitHub account in Sourcetree, then retried the clone, but got the same error.  I then used command line git to clone the repo successfully, then opened it in Sourcetree.  After making code changes, I did a push and was prompted for my password along with a checkbox to save the password to the keychain, which I checked.  After that, the push succeeded.  However each time I did a push, I was reprompted for the password each time.  Quitting and restarting Sourcetree didn't help; obviously the password was either not stored in the keychain, or failed to be retrieved from there.

2 answers

I have the same "User 'xxx' doesn't have the 'Assign Issues' permission" problem

 

The text I tried to send is:

Windows 7 latest updates
Sourcetree for Windows 3.1.3.3158
Embedded git 2.20.1 + git-lfs v.2.6.1

Adding a tag of value1,value2,value3 only displays value1 in the History view.

The Tags view in the left sidebar display the tag correctly

0 votes
Ana Retamal Atlassian Team Aug 20, 2019

Hi @Michael Heins , welcome to the Community!

Thanks for letting us know! You shouldn't be having any problem when trying to submit bugs or feature requests. I've had a look at the form and seems like I've identified where the issue is, I'm sharing this information with the team so we can fix it and it will be possible again for users to report bugs.

In the meantime I've submitted this one on your behalf, you can find it at SRCTREE-6861. Feel free to write a comment if there's something else you'd like to add. 

If there's anything else we can do to help, let us know!

Best regards,

Ana

Ana Retamal Atlassian Team Aug 20, 2019

On response to your issue, you said your passwords are not being stored to your keychain so I think it would be a good idea to rule out a malfunction in Keychain as a cause for this issue. You can check the suggestions in this post or their Help page and find out why the passwords are not being saved. 

Let us know!

Like Michael_Heins likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events