Fixed: The installer for SourceTree update to 2.2.x cannot proceed after logging into id.atlassian.com

I got prompted to update SourceTree from 2.0.x to 2.2.x today. SourceTree downloaded the installer and proceeded to install the update. On restart, SourceTree update installed prompted me to log into my Atlassian account. I did so in the pop-up window provided. Each time I logged in (either using Google auth or the username and password), the pop-up window ended up in my id.atlassian.com account update page (in other words, I am absolutely confident I logged in) with no way to proceed (see attached screenshot):

Screen Shot 2016-04-12 at 10.48.07 AM.png

I tried both using Google OAuth as well as the username/password.

I proceeded to delete the cache in ~/Library/Application Support/SourceTree. This still did not allow me to proceed.

What I need is the ability to proceed past the account page.

 

Update at 9am on 12th April 2016, UTC: I have received a message from Atlassian support that they are currently investigating. Let's hope for a speedy resolution! 

Update 10:30am on 12th April 2016, UTC: The issue is resolved. I have been able to log in - looks like everything is good to go!

Hypothesis is that an update on id.atlassian.com broke login, but this was fixed on the server side. 

33 answers

1 accepted

This widget could not be displayed.

Way too many "me too"s on this. Just vote up the question guys, "me too" is not an answer.

Windows users are having this issue too: https://answers.atlassian.com/questions/38380806

Looks like Atlassian changed something about the id.atlassian.com page that breaks registration.

This widget could not be displayed.

Same deal for me.  Maybe it's something in the name. wink

This widget could not be displayed.

Exactly the same issue here. Tried downloading again and re-installing. Presumably the problem is on their website side.

Hi Jonathan, I have the same issue. If i reinstall, probably i am going to lose my settings. Did it happened to you?

I would assume so but since I can't get through this stage I can't get Sourcetree open to see what settings are there smile

@Alessandro - The update keeps the settings, but deleting the existing config (eg in Libraries/Application Support/SourceTree) will lose your settings

This widget could not be displayed.

I have same problem.

This widget could not be displayed.

I also have this problem with SourceTree for Windows version 1.8.3.

This widget could not be displayed.

Support tickets aren't public, so let us know the outcome of it.

The issue should now be resolved. (Check the Update and comments in OP)

This widget could not be displayed.

Same thing here, cannot use the application at all.

This is on Windows.

This widget could not be displayed.

Same here.

This widget could not be displayed.

Having the same problem here. Hopefully there is a fix available or a solution that comes up.

This widget could not be displayed.

Me too.

This widget could not be displayed.

same too

This widget could not be displayed.

Same problem here also

This widget could not be displayed.

Stopped working today. I am effectively unable to access my repositories. Please fix this ASAP.

This widget could not be displayed.

here also

This widget could not be displayed.

I've the same problem

This widget could not be displayed.

same question...

This widget could not be displayed.

same problem

This widget could not be displayed.

Me too.

This widget could not be displayed.

same with me ...

 

This widget could not be displayed.

I stay to the old version, same problem

This widget could not be displayed.
This widget could not be displayed.

same problemo!!!!!!!

 

This widget could not be displayed.

same issue here

This widget could not be displayed.

Same here, can't proceed after successful login.

This widget could not be displayed.

Me too.

This widget could not be displayed.

same here; must be a server problem. Hopefully they'll wake up soon wink

I just saw your update, thank you!
It is good to know they work on it!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

879 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you