Finish Feature not finishing

Sourcetree Version 2.3.5.0

 

Hi

I am a solo Web developer and use GIT and Sourcetree to keep track of my changes.

I use Master branch for updating and obviously Development for changes.

I mainly use origin (Bitbucket) for back up.

While developing, my plan is to make features to test and add changes, if it works, I want to push it back to development and after testing, merge with Master which I will load to live site.

Creating features works, but I can not get them to finish and merge back to Development.

Sourcetree just hangs trying to finish the tree. No errors, nothing. It just shows running screen but never finish. If I create a new feature and then finish it, it works. If I make changes and commit, it just hangs.

Any help would be appreciated, I really want to use the feature. Sorry for the TL;DR

Attached you will find a screen shot of my tree as well as my git config.

sourcetree.JPG

And my git config:

[core]
    repositoryformatversion = 0
    filemode = false
    bare = false
    logallrefupdates = true
    symlinks = false
    ignorecase = true
    hideDotFiles = dotGitOnly
[gui]
    wmstate = normal
    geometry = 887x427+156+156 199 192
[remote "origin"]
    url = [REMOVED FROM TEXT]
    fetch = +refs/heads/*:refs/remotes/origin/*
[branch "master"]
    remote = origin
    merge = refs/heads/master
[gitflow "branch"]
    master = master
    develop = development
[gitflow "prefix"]
    feature = feature/
    release = release/
    hotfix = hotfix/
    versiontag =
[user]
    name = [REMOVED FROM TEXT]
    email = [REMOVED FROM TEXT]
[branch "development"]
    remote = origin
    merge = refs/heads/development
[pack]
    buildbitmaps = false
[gitflow "branch.feature/single_dealer"]
    base = development
[gitflow "branch.feature/Car_import_V2"]
    base = development
[gitflow "branch.feature/auction_processing"]
    base = development
[branch "feature/auction_processing"]
    remote = origin
    merge = refs/heads/feature/auction_processing
[gitflow "branch.feature/car_search"]
    base = development
[branch "feature/car_search"]
    remote = origin
    merge = refs/heads/feature/car_search

2 answers

1 accepted

0 votes
Accepted answer

Updated embedded GIT. had error extracting, but it done it.

Did another test, now it works.

Thanks so much!

Q..

Hi,

Congrats! you could solve the issue. I am also having the same problem, but I could not fix it. Can you help me to solve the issue please. I would appreciate your help. Thanks in advance.

All I did was to update my GIT version. See below

I have also tried after update the git version but it's still not working.

Sketch_3.png

0 votes

Hi

You said 'Sourcetree just hangs trying to finish the tree' can you explain a bit more about this?

Is the tree the log view?
Looking at the image you posted, I assume you think it is wrong, what are you expecting to see?
How do you merge your feature branches?

Sorry, 'finish the tree' was the wrong wording. I meant finish the feature, using Git Flow.

The image is the log view, showing 2 branches with features just hanging, because I cant get them to finish.

These are my steps:

I commit devel

I then create a feature with Git flow. (from devel)

start feature.JPG

Work on it and commit.

Now I want to close it and merge back to devel:

So I click on Git Flow, and then click finish the feature.

feature close.JPG

feature close 2.JPG

This is where the problem starts:

It hangs just doing this, noting else happens. No errors or anything. It just hangs there trying to complete the feature with the bar running the whole time

Capture.JPGfeature close 3.JPG

What version of git are you running, see the  Tools/Options/Git tab

Ah you will need a 2.x version of Git preferably 2.18 or higher.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

848 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you