Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Errors when attempting to switch branches & when pushing Github

Cole - Nova - Andrews
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Jun 16, 2023

Hey all! 

Alright so super noob here I was attempting to use Sourctree (and github) as a means of source control for my project in Unreal Engine 5. The first couple commits & pushes were fine as I had no large files. 

Eventually once I had some larger files I got the initial stage error/warning saying I had large files, I ignored this as I did want those files to be included - many of them are vital to the overall functioning of the project. However, when I would actually try and push (after staging and committing) I'd get post buffer errors and would ignore the issue (leaving it as a commit pretty much). 

Fast forward to tonight I have three branches: Main, Combat, ALS. Combat is where my previous three commits are and ALS was a new branch I made as I was about to start working on a new system that may or not break a lot of things. I tried pushing per usual and once again got a post buffer error, however this time it recommended I try git LFS, great! 

Downloaded git LFS and seemingly set it up (as I'm new to git I can never really tell), and then double-clicked on my combat branch... wait did I just swap branches? 

Booted up my project and yeah, I went back to a commit when I swapped branches, from what I can tell at least, from many days ago. Now when I attempt to swap back over to the ALS branch where I actually need to do the work, and where all my progress up to now is stored, I get the following error (see image). image_2023-06-16_034006296.png

I've tried looking up solutions already but they all seem risky for a noob like me and I'd rather not lose days of work because of a stupid mistake. 


So a couple things I'm looking for: 
1. How do I fix the error in the image? 
2. In the future what can I do to prevent postbuffer/LFS errors? I tried pushing once I had LFS installed but it didn't really seem to do me any good. Do I need to manually choose which files are sent to LFS vs git ?

Sorry for the ramble and thanks for your help!

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events