It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Don't prompt for username and password

Every time I launch Sourcetree, it prompts me for my Github credentials. I only use Sourcetree for local operations (stage, branch and commit). How can I disable Github from constantly nagging me for my username and password?

2 answers

1 accepted

0 votes
Answer accepted

Rolling back to version 2.7 resolves this.

0 votes
Mike Corsaro Atlassian Team Jan 03, 2019

Under "Accounts" in settings you'll probably see a github account. You can try removing that and seeing if that fixes it.

 

What version of Sourcetree are you using?

I've seen this behavior in version 2.7.4 and 3.0.

Under Preferences - Accounts there are no accounts. It still prompts me for a username/password. The exact prompt is (URL edited out):

prompt.png

 

My .git/config's [remote "origin"] points to a github URL.

 

Edit: 2.7 does not prompt for Github credentials, 2.7.4 does.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,895 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you