Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,180
Community Members
 
Community Events
176
Community Groups

Disable smart quotes in commit window?

Is there a way to permanently disable smart quotes and smart dashes in the commit window? Some of our deploys fail because git complains about the unicode characters.

When I right-click and uncheck Substitutions > Smart Quotes and Substitutions > Smart Dashes it does not remember the setting.

It would be ideal to be able to turn off all spelling "correction" and any other text substitions in this window.

I'm on OS 10.9 and Sourcetree 1.7.4.1.

Thanks.

5 answers

LOL, I just found this issue, and it's EIGHT YEARS OLD.

Obviously, Atlassian doesn't care about their users. Never has, never will.

I think SourceTree should just always disable the various "smart" substitutions in the commit dialog. The will almost never make sense, and if somebody wants to use "smart" quoties etc., well, they can still enter them manually.

I had to turn off the setting site wide in order to prevent sourcetree from replacing quotes and dashes in the commit dialog. Ideally it could be disabled just for sourcetree, but this works for me for now.

Go to System Prefs > Keyboard

Choose the Text tab.

Uncheck "Use smart quotes and dashes"

Same over here! This is *reall* annoying. For now I partially worked around this by changing the system wide "smart dash" settings to use the regular " and ' (so nothing happens), but this is only partially solving the problems, as it still converts -- to a dash.

I really hope the SourceTree team will fix this soon.

I'm experiencing the same issue with OSX 10.8.5 and Sourcetree 1.8.0.3.

I've resorted to using the command line for my recent usage of git, as I cannot seem to turn off text substitutions permanently for SourceTree, even though I've turned them off system wide.

The text substitution settings reset as soon as I hit the "commit" button again.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events