Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,448
Community Members
 
Community Events
177
Community Groups

Cloning over SSH Doesn't Work for a Remote Account When Repo Has a Submodule

Edited

I hope that subject line isn't confusing. :)

I am using Sourcetree and am pretty familiar with Git having used it via Bash for several years now. In Sourcetree if I take the repository URL that is hosted in Bitbucket which looks like:

git@bitbucket.org:team/repository.git

Then select Clone, add in the URL, choose Advanced Options and select Recurse Submodules - this will clone successfully.

If instead I add a Remote Account (which Sourcetree tells me makes cloning even easier (!)), search for my repository and then select Clone, it will clone the supermodule, but fail on the submodule with the error "fatal: error in sideband demultiplexer"

Which I have no idea what it means.

My Sourcetree settings are:

SSH Key is loaded via SSH Client PuTTY/Plink. This loads automatically and I enter my passkey and I can see it in the taskbar process. My public key is added to Bitbucket. I am on Sourcetree version 2.6.10.0 and Authenticaion is set to:

  • Hosting Service - Bitbucket
  • Protocol: SSH
  • Auth: OAuth
  • Username: iansmithers
  • With Authentication: OK showing and a green tick.

I've spent a few hours trying to figure out what this may be, and have cloned several submodule enabled repositories to see if it is isolated, but it isn't. It happens on them all - only when selecting 'Clone' from the Remote repositories screen. If I manually paste the clone URL in it works fine. Very confused.

2 answers

1 accepted

6 votes
Answer accepted
Pravin Atlassian Team Sep 04, 2018

Hi Ian, 

As discussed through the Support Ticket.

After several testing, I'm suspecting that error "error in sideband demultiplexerappears related to Putty SSH Agent. Git Bash uses Open SSH by default and Source Tree uses Putty SSH Client by default. 

Since it works on Git Bash which uses Open SSH, changing Source Tree to use Open SSH for its SSH Client works as you have tested. I would suggest to changing it to use OpenSSH as the SSH Client moving forward. 

To change SSH Client on Source Tree, navigate to : Tools > Options > General >> SSH Client Configuration >> SSH Client > Select OpenSSH. 

Thanks.
Pravin

Thanks Pravin, pleasure dealing with you btw and much appreciated the assistance. :)

Like Pravin likes this

There is no Tools > Options > General on source tree for mac version 3.2.1

Been searching on how to resolve and hope someone somewhere has an answer as to why cmd line clone works and sourcetree doesn't 

So for anyone out there, I found the user account SSH key and not local machine key resolved my issue. as using command line git works fine with local machine, but source tree account being used wouldn't clone unless configured properly.

I was having a similar problem with cloning failing. Capturing network traffic showed that the Bitbucket server was simply dropping the SSH connection. 

Upgrading the embedded version of Plink to 0.73 fixed the issue for me.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events