Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,338
Community Members
 
Community Events
176
Community Groups

Can't change Sourcetree diff/merge tool

I originally setup SourceTree to use TortoiseGitMerge as my merge tool of choice. I finally ran into a situation where I needed to do a merge and TortoiseGitMerge would throw an error about not being able load the files. To try and solve this issue I decided to try hard coding some paths to see if I could TortoiseGitMerge to run properly. That didn't work so I moved on and tried a few more things. Eventually I gave up and decided to try using BeyondCompare instead. Except, no matter what I do SourceTree keeps launching TortoiseGitMerge. The only way I can get it to not launch TortoiseGitMerge  is to change it to System Default in which case SourceTree just hangs.

I've deleted my settings, restarted my computer, deleted my settings about 400 times again, reinstalled SourceTree, deleted everything I can find related to SourceTree then reinstalled. And still no matter what I do SourceTree keeps launching TortoiseGitMerge. The only change in behavior I've found is if I uninstall TortoiseGit SourceTree hangs because it can't find the executable.

I've followed the steps mentioned here and that hasn't helped. Why is SourceTree still trying to run TortoiseGitMerge even after I've deleted all the settings files I can find?

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events