Beyond Compare 4.1.5 (64-bit Edition) stopped working as Externa Diff Tool

We installed yesterday "Beyond Compare 4.1.5" (64-bit Edition) on Windows 10 Pro (Version 10.0.10586). In the Options Window of "SourceTree" 1.8.3.0 (under tab "Diff"), we set the External Diff Tool to: "Beyond Compare", but we kept the Merge Tool to: "System Default". It worked fine yesterday but not today. I tried all propositions found on the internet (including yours: I put both selections to: "System Default", shut down "SourceTree", then reloaded it to set both selections to: "Beyond Compare"). I also tried with settings both fields to" "Custom" selections, with the proper command line and arguments (I made different attempts from what I found on the internet), but nothing works. After trying to run  load External Diff, the cursor is flickering a little at moments, but nothing happens. If I load "Beyond Compare" by itself, it works fine. Do you have any suggestion? Thank you!

2 answers

Sounds like some good troubleshooting so far. Have you tested with any other diff tools?

Thanks for your prompt answer! I forgot to mention that I also tried today to set the External Diff Tool to: "WinMerge" (with Merge Tool set to: "System Default" as "WinMerge" is not an option there) and it does not work neither (which used to work also as I switched yesterday from "BeyondCompare" to "WinMerge", did some tests then went back to "BeyondCompare" as my External Diff Tool)...

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

994 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you