Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Authentication issues

Hi,

My team and I use SourceTree to merge our work, however, I have encountered a problem when I use the Fetch, Push, or Pull buttons.

It says that I have an authentication issue. 2021-01-12_10-10-55.pngMy IT team tried to help but failed. Do you have any suggestions? I'd appreciate all the help I could get since it is blocking my work at this point.

Looking forward to hearing from you.

Best,

Jasmina

 

2 answers

2 accepted

1 vote
Answer accepted

This just started happening to me today after I updated Sourcetree yesterday afternoon to the latest version.

 

Might have to dump and go back to an earlier version.  Even after I authenticate with the Captcha in my Bitbucket Server in the web browser it still won't authenticate.

Switching from Git 2.29 to 2.30 seemed to fix it for me.  There were other issues with Git 2.29 not adding files to the repo in addition to the auth problems we had when we upgraded.

 

I went with System Git instead of embedded.

 

I will check the Oauth option to see what it is currently set at.

0 votes
Answer accepted

I've had the same issue.  After poking around a bit, I did the following to fix it:

1. Go to Tools --> Options

2. Select Authentication

3. Select the GitHub account that you use for the project

4. Click on Edit

5. In the Credentials box, change your authentication method from Basic to OAuth

That did it for me - hope this helps.

Elisa

With our Bitbucket Server account, I don't have the option under Tools>Credentials>Authentication>repo account>Credentials>Authentication

for Oauth - the only thing on the drop down for me is Basic.

Switching Git versions to the latest seemed to fix a whole raft of issues I had on the initial upgrade to Sourcetree to 3.4.2

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events