Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,196
Community Members
 
Community Events
176
Community Groups

Are .vscode/* and .vscode/ indeed different or is it just Sourcetree not working right?

I'm not so familiar with CLI git so I use Atlassian's Sourcetree to manage my Git.

However, I've found out that Sourcetree doesn't recognize .gitignore's directory with tailing asterisk(*).

i.e, .vscode/ is ignored while .vscode/* is not ignored.

Items like .vscode/settings.json keep appearing in the unstaged area.

As far as I know, * is a wildcard for any file/subdirectory in the directory so this should not happen.

My .gitignore extension creates all the items like /* so now I have to manually change all that to / to avoid staging what I don't wanna commit.

 

I can't test out if this is a normal behavior in any Git applications or the native git itself because Sourcetree is the only Git management I know of. Is it something that would also happen in traditional CLI git?

1 answer

1 accepted

0 votes
Answer accepted
DPKJ Community Leader Sep 01, 2019

@chlwovlfgit be default uses globbing patterns (https://linux.die.net/man/7/glob)

There can be two reasons with SourceTree behaviour,

  1. Sourcetree has some issue with pattern matching etc. (may be a bug)
  2. Your folder `.vscode` was earlier part of git and you have removed it just by adding to '.gitignore' and have not removed it from git  itself.
    1. If this is the case, try
    2. # git rm --cached -r .
      # git add .

       

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events