Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
Highlighted

Sourcetree very slow with Avast shields enabled Edited

Hi I've been encountering issues with Sourcetree running incredibly slowly, with response times around 10 seconds. However I have noticed that if I temporarily disable my Avast shields Sourcetree becomes instantly responsive. I'm posting this because in my searches I have noticed a lot of people complaining about this issue and tampering with all sorts of settings with varying or marginal results.
Anyway I'm just curious to see if anyone else using Avast + Sourcetree has had a similar experience to me and possibly if they know why or to suggest a course of action short of changing Antivirus software that might make things a bit easier.

1 comment

I solved the issue as follows:

1) open Avast

2) go to the panel Settings\Components\Protectin FileSystem\Exclusions 

3) add C:\Users\LOCAL_USER\AppData\Local\Atlassian\SourceTree\* and check only "E"

4) add C:\Users\LOCAL_USER\AppData\Local\SourceTree\* and check only "E" too 

 

Interesting, I did as you said and could not find a box listed under E, instead I had the options "R" (Read) "W" (Write) and "X" (Execute). I assumed that the "E" you mentioned would likely also mean execute in this context. However, I have not noticed any difference in the issue using these instructions so I'm going to trust your judgement and assume I have not followed them correctly.
Another difference I have noticed is "Protectin FileSystem" is not an option on my components list, but instead "File System Shield" was the component in which I modified the exclusions.

 

Note in the screenshot I currently have my file shields disabled as I'm working on a project right now.
AvastScreenShot.png

Pretty old thread but just in case someone is having the same issue you need to follow the steps described by @Carlo di Salvatore although the component is now called "Behaviour Shield".

Comment

Log in or Sign up to comment
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,496 views 19 19
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you