SourceTree 2.6.3 (2.6.x) for Mac is horribly slow

Hi there.

With new design the app acquires a totally slow working. It regularly freezes and loads CPU a lot.

I've downgrade to 2.5.3 version and I got added evidence that the 2.6 is a problem. The 2.5.3 version works normally.

22 comments

It is also very slow for me. Activity Monitor shows it taking 100% CPU (with a dual core) when switching focus between files in the Unstaged files list.

SourceTree 2.6.3, OSX 10.11.6.

Generating visual diffs is a complex task within Sourcetree, how large are the files/changesets you're navigating between?

Same here... on 10.12.6 and upgraded from 2.5.3... I'm on a 12-core mac pro and it's slow! working on the same project I have been for the past months and it's clear it's *much* slower.

Note one thing to check is if you're running something like dropbox... I kill dropbox while developing as it's seriously a slow POS

Me too.  Frequent spinning wheel after a source code change.

 

Underlying git is 2.10.1

 

I might be imagining it, but a restart seems to help (!)

Ditto on 2.6.3 being horribly slow. I've had to force quite multiple times after simply opening a repo (no complex compare, and doesn't matter what size the repo)

Downgrading to 2.5.3 and everything is back to normal. 

Me too. It's driving me potty. Just opening a repo view from the repo list takes almost 5 seconds.

As you're all saying - it was fine with 2.5.x

I'm experiencing the same issue. It's very slow when clicking between files and always spins the loader cursor for a long time. It worked just fine before the update.

I get literally five seconds of spinning beachball or a stuck cursor in between just about every operation I do. This is not even that crazy of a repo. It gets worse the longer that SourceTree has been open for.

I downloaded Git Tower and Git Kraken, and both of them are blazingly fast on my 2.8 GHZ top of the line MacBookPro from mid-2015. 

There is no excuse for how painfully slow SourceTree is, in this version. Do you guys even performance test, bro?

I prefer SourceTree's UI, and it's what I'm used to. However this particular version is so slow that it is basically unusable. 

Someone who knows what O(N^N^N^N) means should look at your code.

SourceTree 2.6.3 seems incredibly slow on Mac. I suggest you consider rollbacking all changes and put this as bug as blocker, it makes SourceTree pretty much unusable.

Also having this issue on OSX 10.13.1 2017 macbook pro for Sourcetree v2.6.3. It crashed while I was trying to checkout a branch, and I've noticed that even resizing the window running the app is very slow. 

Downgrading to 2.5.3 also seems to work better for me.

It's gotten worse and really killed the workflow... our shop is looking for alternatives since Atlassian folks seemed to be still celebrating and maybe a bit tipsy from all the IPO champagne... sad as I've loved the products, but we're not forced by IT to use whatever is rammed down... it's time to find a toolchain that works built by folks that I guess are hungry.

Some here ... High Sierra 10.13.1 ... SourceTree 2.6.3

 

Unusable. GIT checkout takes forever.

Same here, same versions

Same with SourceTree 2.7 and El Capitan 10.11.6!

Even navigating through file changes is painfully slow!

Same its been unusable for months 

 

2.6.x sourcetree 

10.11.6  macOS 

I rolled back to 2.5.3 from the Download Archives and turned off check for updates until there is an indication this has been addressed.  Good luck all!

Quentin Neves I'm New Here Thursday

Gonna do the same, eight month later, 2.7.whatever, same perf issues. Hopefully i'm used to git commands so I can do without it. But for some tasks (i.e. resolving conflicts) it can be very useful, and for those not used to type commands.

I can really recommend this - I've done it and am still happily using 2.5.3, six months later.

Version 2.7 (152)

High Sierra 10.13.2

Mercurial

 

VERY slow for me. Clicking on various revisions is very slow. 5-7 seconds with only 1-2 files changed.

Less than half the time when I switch to the system Mercurial instead of the embedded one.

Same – Sourcetree 2.7 is hammering my CPU. I only have a couple files open, and they're all <5KB. It brings my entire computer to a crawl sometimes, for a minute or two (which is forever in developer time).

Mac OS 10.11.6, Core i7 2.3GHz 8GB

Downgrading to 2.5.3 seems to have fixed it. Wtf...

I tried your recommendation as well, and it is like using a completely different application.  Night and day difference.  2.7 is VERY broken, and basically unusable on my 2009 macbook with El Capitan.  These are the most basic of operations as well, with not many pending changes.  Additionally it lags on submodule updates HORRIBLY.

I hadn't noticed until I was replying to your post, but I'm also on 10.11.6

I can second this - 2.6.x and 2.7.x both uselessly slow for even very small changesets on my 2015 Retina Macbook Pro.  I'd tried using System Git, turning off diff altogether and was eventually just using Sourcetree to see an overview of changes then using the command line to run diffs, build commits etc.

Downgrading to 2.5.3 has worked great and I'm now actually able to use Sourcetree as I used to - wish I'd thought of this myself!

Yeah I am convinced /s this is Atlassian's passive aggressive way of encouraging us to use git through the command line. 

Thanks for the great idea about downgrading; it never occurred to me to try.  Downgrading improved performance, though I wouldn't quite call it snappy yet. Another benefit for me is that it fixed push, which broke a while back and I'd just been doing from the command line ever since.

Even though I've only worked in Mercurial for the past few days, SourceTree seems to have spawned a zillion git, git-credential-sourcetree, and git-remote-https processes that don't go away after quitting.  I wonder if clearing out my git repository bookmarks would help with all that.

FYI, downgrading to 2.5.3 did not work for me. I had to go all the way back to 2.1 for the slowness to go away. It's lightning fast again, been struggling with this for 2 years.

SourceTree 2.7.3 (4.0GHz i7 27" Retina iMac, 32GB)

I think it might be related to Retina displays? On my old 13" MacBook Air Sourcetree works fine, but on my i7 4.0GHz Retina 5K iMac it is utterly slow. Even typing of commit message has a ~1 sec lag before letters appear on the screen.

All other operations are also slow as hell. Every single change of view takes at least few seconds.

I agree that it gets worse when SourceTree is running for a long time. I restart it every day.

Probably also the number of opened repositories (windows) is important for performance.

One trick that improved CPU usage: I have disabled automatic refresh of local repository (it was triggered every time after new classes were compiled). Now I have to refresh manually but it is faster. For convenience, I have added the refresh button to the taskbar.

How do you "add a refresh button to the taskbar"?

Right click on toolbar, choose 'Customize Toolbar...' and drag refresh button to it.

tehfink I'm New Here Aug 24, 2018

Same problem on Mac OS X 10.13.4 with SourceTree 2.7.6: cripplingy slow, even on new & empty hg repositories.

It's really horribly slow.

Whatever you do, it just occupies almost all of the cpu, and takes really long time to respond.

 

 

MAC

10.12.6 (16G1510)

SourceTree

2.7.6 (177)

Embedded Git 2.17.1

Embedded git-lfs 2.4.2

Bitbucket Media Adapter 1.0.6

Embedded git-flow

Embedded Mercurial 4.6.1

SmartGIT has come a ways recently.  I'm on a beta preview for release soon (obtained when I complained about something they have fixed in that release).

Now that it draws the branch tree as well as (even with better features than) SourceTree there's no reason not to swap if your organisation will pay or you're a non-commercial user.

Comment

Log in or Sign up to comment
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

883 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you